VPS侦探论坛

 找回密码
 注册
查看: 114|回复: 1

银河麒麟一键安装,PHP安装失败

[复制链接]
发表于 2022-1-5 11:58:04 | 显示全部楼层 |阅读模式



checking for strings.h... (cached) yes
checking io.h usability... no
checking io.h presence... no
checking for io.h... no
checking for strtoll... yes
checking for atoll... yes
checking whether to enable LIBXML support... yes
checking libxml2 install dir... /usr
checking for xml2-config path... /usr/bin/xml2-config
checking whether libxml build works... yes
checking for OpenSSL support... yes
checking for Kerberos support... no
checking whether to use system default cipher list instead of hardcoded value... no
checking for RAND_egd... no
checking for pkg-config... /usr/bin/pkg-config
checking for PCRE library to use... bundled
checking whether to enable PCRE JIT functionality... yes
checking whether to enable the SQLite3 extension... yes
checking bundled sqlite3 library... yes
checking for ZLIB support... yes
checking if the location of ZLIB install directory is defined... no
checking for zlib version >= 1.2.0.4... 1.2.11
checking for gzgets in -lz... yes
checking whether to enable bc style precision math functions... yes
checking for BZip2 support... no
checking whether to enable calendar conversion support... no
checking whether to enable ctype functions... yes
checking for cURL support... yes
checking for libcurl.pc... using default path
checking for cURL 7.15.5 or greater... configure: error: cURL version 7.15.5 or later is required to compile php with cURL support
make: *** No targets specified and no makefile found.  Stop.
make: *** No targets specified and no makefile found.  Stop.
make: *** No rule to make target 'install'.  Stop.
Copy new php configure file...
Modify php.ini......
include/php.sh: line 86: pear: command not found
include/php.sh: line 87: pecl: command not found

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2022-1-5 18:30:17 | 显示全部楼层


lnmp未适配过银河麒麟,仅按目前提供的信息看
Last metadata expiration check: 0:00:28 ago on Wed 05 Jan 2022 11:04:13 AM CST.
No match for argument: curl-devel
Error: Unable to find a match: curl-devel
Last metadata expiration check: 0:00:28 ago on Wed 05 Jan 2022 11:04:13 AM CST.
Package curl-7.66.0-2.ky10.aarch64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
Last metadata expiration check: 0:00:29 ago on Wed 05 Jan 2022 11:04:13 AM CST.
No match for argument: libcurl-devel
Error: Unable to find a match: libcurl-devel

除这些外还有其他一些基本的依赖包都不存在
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2022-1-19 18:36 , Processed in 0.044214 second(s), 17 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表