VPS侦探论坛

 找回密码
 注册
查看: 567|回复: 3

centeros6 lnmp1.8 php7.0安装失败

[复制链接]
发表于 2022-2-9 15:53:59 | 显示全部楼层 |阅读模式

configure: error: in `/home/lnmp1.8/src/php-7.1.33':
configure: error: C compiler cannot create executables
See `config.log' for more details
make: *** No targets specified and no makefile found.  Stop.
make: *** No targets specified and no makefile found.  Stop.
make: *** No rule to make target `install'.  Stop.
Copy new php configure file...
Modify php.ini......
include/php.sh: line 86: pear: command not found
include/php.sh: line 87: pecl: command not found
Downloading Composer...
--2022-02-09 15:51:23--  https://soft.vpser.net/web/php/composer/composer.phar
Resolving soft.vpser.net... 81.70.180.148
Connecting to soft.vpser.net|81.70.180.148|:443... connected.
HTTP request sent, awaiting response... 302 Moved Temporarily
Location: http://175.6.32.4:88/soft/web/php/composer/composer.phar [following]
--2022-02-09 15:51:23--  http://175.6.32.4:88/soft/web/php/composer/composer.phar
Connecting to 175.6.32.4:88... connected.
HTTP request sent, awaiting response... 200 OK
Length: 2358836 (2.2M) [application/octet-stream]
Saving to: “/usr/local/bin/composer”


不管是7.0还是7.1编译这一步就出问题了

美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2022-2-9 16:11:43 | 显示全部楼层


本帖最后由 翼德1 于 2022-2-9 16:12 编辑

已经安装了gcc,也没有看到config.log在哪

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有账号?注册

x
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
发表于 2022-2-9 19:39:56 | 显示全部楼层

Loaded plugins: security
Setting up Install Process
Repository base is listed more than once in the configuration
Repository updates is listed more than once in the configuration
Repository extras is listed more than once in the configuration
Repository centosplus is listed more than once in the configuration
Repository contrib is listed more than once in the configuration

首先你这系统源有可能设置了多次
其次你这系统PATH可能设置有问题,可以 echo $PATH 看看
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2022-2-23 12:02:08 | 显示全部楼层



1.8版本程序安装要求里面写的很清楚,已经不支持你这个系统版本了
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2022-5-27 21:24 , Processed in 0.017145 second(s), 17 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表