VPS侦探论坛

 找回密码
 注册
查看: 465|回复: 10

lnmp安装失败但是没找到具体的原因,请大佬帮帮忙看看

[复制链接]
发表于 2022-2-23 16:07:45 | 显示全部楼层 |阅读模式

具体内容如附件,安装的是lnmp环境。

文件我上传到附件里面了,还请大佬们帮忙看看问题。

发帖如果不规范的地方还请指教。

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有账号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2022-2-23 19:49:35 | 显示全部楼层


yum源404了,换源后再试一下
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
发表于 2022-2-23 20:29:07 | 显示全部楼层

Loading mirror speeds from cached hostfile
http://yum.tbsite.net/centos/7/os/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
To address this issue please refer to the below wiki article

https://wiki.centos.org/yum-errors

If above article doesn't help to resolve this issue please use https://bugs.centos.org/.



One of the configured repositories failed (CentOS-7),
and yum doesn't have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Run the command with the repository temporarily disabled
            yum --disablerepo=base ...

     4. Disable the repository permanently, so yum won't use it by default. Yum
        will then just ignore the repository until you permanently enable it
        again or use --enablerepo for temporary usage:

            yum-config-manager --disable base
        or
            subscription-manager repos --disable=base

     5. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice
        compromise:

            yum-config-manager --save --setopt=base.skip_if_unavailable=true

failure: repodata/repomd.xml from base: [Errno 256] No more mirrors to try.
http://yum.tbsite.net/centos/7/os/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found

系统源没设置正确是无法安装的,如何设置可以论坛搜索:CentOS更换源
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2022-2-24 09:36:11 | 显示全部楼层



licess 发表于 2022-2-23 20:29
系统源没设置正确是无法安装的,如何设置可以论坛搜索:CentOS更换源

做了本地源后不知道为啥还是出错了,昨天还特地用自己电脑的虚拟机下掉网卡做离线安装,相同系统Centos7.6.1810的虚拟机下掉网卡做离线安装就可以,但是用服务器的就不行。附件我重新上传一个了
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2022-2-24 09:37:17 | 显示全部楼层

这个是第二次用了本地源后的附件

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有账号?注册

x

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

 楼主| 发表于 2022-2-24 09:38:34 | 显示全部楼层

锦帆君 发表于 2022-2-23 19:49
yum源404了,换源后再试一下

第二次换了本地源了还是不行,虚拟机下掉网卡离线安装就可以
 楼主| 发表于 2022-2-24 10:02:33 | 显示全部楼层

这些是一些相关的内容,还请大佬们帮忙看看具体原因是什么,辛苦大佬们了

[root@wy19twks ~]# ll /etc/yum.repos.d/
total 20
-rw-r--r-- 1 root root 577 Jan 19 09:03 base.repo.bak
-rw-r--r-- 1 root root 603 Jan 14 16:03 CentOS-Base.repo.bak
-rw-r--r-- 1 root root 137 Feb 24 08:54 CentOS-Media.repo
-rw-r--r-- 1 root root 206 Jan 14 16:04 epel.repo.bak





[root@wy19twks ~]# cat /etc/yum.repos.d/CentOS-Media.repo
[local-media]

name=CentOS-$releasever - Media
baseurl=file:///mnt/dvd/
gpgcheck=1
enabled=1
gpgkey=file:///mnt/dvd/RPM-GPG-KEY-CentOS-7






[root@wy19twks ~]# ll /mnt/dvd/
total 686
-rw-rw-r-- 1 root root     14 Nov 26  2018 CentOS_BuildTag
drwxr-xr-x 3 root root   2048 Nov 26  2018 EFI
-rw-rw-r-- 1 root root    227 Aug 30  2017 EULA
-rw-rw-r-- 1 root root  18009 Dec 10  2015 GPL
drwxr-xr-x 3 root root   2048 Nov 26  2018 images
drwxr-xr-x 2 root root   2048 Nov 26  2018 isolinux
drwxr-xr-x 2 root root   2048 Nov 26  2018 LiveOS
drwxrwxr-x 2 root root 663552 Nov 26  2018 Packages
drwxrwxr-x 2 root root   4096 Nov 26  2018 repodata
-rw-rw-r-- 1 root root   1690 Dec 10  2015 RPM-GPG-KEY-CentOS-7
-rw-rw-r-- 1 root root   1690 Dec 10  2015 RPM-GPG-KEY-CentOS-Testing-7
-r--r--r-- 1 root root   2883 Nov 26  2018 TRANS.TBL






[root@wy19twks ~]# ll /home/ | grep Cent
-rw-r--r-- 1 root root 4588568576 Feb 24 09:04 CentOS-7-x86_64-DVD-1810.iso
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2022-2-24 12:08:32 | 显示全部楼层

一岁呀 发表于 2022-2-24 09:37
这个是第二次用了本地源后的附件
Loading mirror speeds from cached hostfile
Resolving Dependencies
--> Running transaction check
---> Package krb5-devel.x86_64 0:1.15.1-34.el7 will be installed
--> Processing Dependency: libkadm5(x86-64) = 1.15.1-34.el7 for package: krb5-devel-1.15.1-34.el7.x86_64
--> Processing Dependency: krb5-libs(x86-64) = 1.15.1-34.el7 for package: krb5-devel-1.15.1-34.el7.x86_64
--> Processing Dependency: libverto-devel for package: krb5-devel-1.15.1-34.el7.x86_64
--> Processing Dependency: libselinux-devel for package: krb5-devel-1.15.1-34.el7.x86_64
--> Processing Dependency: keyutils-libs-devel for package: krb5-devel-1.15.1-34.el7.x86_64
--> Running transaction check
---> Package keyutils-libs-devel.x86_64 0:1.5.8-3.el7 will be installed
---> Package krb5-devel.x86_64 0:1.15.1-34.el7 will be installed
--> Processing Dependency: krb5-libs(x86-64) = 1.15.1-34.el7 for package: krb5-devel-1.15.1-34.el7.x86_64
---> Package libkadm5.x86_64 0:1.15.1-34.el7 will be installed
--> Processing Dependency: krb5-libs(x86-64) = 1.15.1-34.el7 for package: libkadm5-1.15.1-34.el7.x86_64
---> Package libselinux-devel.x86_64 0:2.5-14.1.el7 will be installed
--> Processing Dependency: libsepol-devel(x86-64) >= 2.5-10 for package: libselinux-devel-2.5-14.1.el7.x86_64
--> Processing Dependency: pkgconfig(libsepol) for package: libselinux-devel-2.5-14.1.el7.x86_64
--> Processing Dependency: pkgconfig(libpcre) for package: libselinux-devel-2.5-14.1.el7.x86_64
---> Package libverto-devel.x86_64 0:0.2.5-4.el7 will be installed
--> Running transaction check
---> Package krb5-devel.x86_64 0:1.15.1-34.el7 will be installed
--> Processing Dependency: krb5-libs(x86-64) = 1.15.1-34.el7 for package: krb5-devel-1.15.1-34.el7.x86_64
---> Package libkadm5.x86_64 0:1.15.1-34.el7 will be installed
--> Processing Dependency: krb5-libs(x86-64) = 1.15.1-34.el7 for package: libkadm5-1.15.1-34.el7.x86_64
---> Package libsepol-devel.x86_64 0:2.5-10.el7 will be installed
---> Package pcre-devel.x86_64 0:8.32-17.el7 will be installed
--> Finished Dependency Resolution
Error: Package: libkadm5-1.15.1-34.el7.x86_64 (local-media)
           Requires: krb5-libs(x86-64) = 1.15.1-34.el7
           Installed: krb5-libs-1.15.1-37.el7_6.x86_64 (@updates)
               krb5-libs(x86-64) = 1.15.1-37.el7_6
           Available: krb5-libs-1.15.1-34.el7.x86_64 (local-media)
               krb5-libs(x86-64) = 1.15.1-34.el7
Error: Package: krb5-devel-1.15.1-34.el7.x86_64 (local-media)
           Requires: krb5-libs(x86-64) = 1.15.1-34.el7
           Installed: krb5-libs-1.15.1-37.el7_6.x86_64 (@updates)
               krb5-libs(x86-64) = 1.15.1-37.el7_6
           Available: krb5-libs-1.15.1-34.el7.x86_64 (local-media)
               krb5-libs(x86-64) = 1.15.1-34.el7
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Package libidn-1.28-4.el7.x86_64 already installed and latest version
Nothing to do
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
No package libidn-devel available.
Error: Nothing to do
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Package matching 1:openssl-1.0.2k-16.el7.x86_64 already installed. Checking for update.
Nothing to do
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Resolving Dependencies
--> Running transaction check
---> Package openssl-devel.x86_64 1:1.0.2k-16.el7 will be installed
--> Processing Dependency: openssl-libs(x86-64) = 1:1.0.2k-16.el7 for package: 1:openssl-devel-1.0.2k-16.el7.x86_64
--> Processing Dependency: krb5-devel(x86-64) for package: 1:openssl-devel-1.0.2k-16.el7.x86_64
--> Running transaction check
---> Package krb5-devel.x86_64 0:1.15.1-34.el7 will be installed
--> Processing Dependency: libkadm5(x86-64) = 1.15.1-34.el7 for package: krb5-devel-1.15.1-34.el7.x86_64
--> Processing Dependency: krb5-libs(x86-64) = 1.15.1-34.el7 for package: krb5-devel-1.15.1-34.el7.x86_64
--> Processing Dependency: libverto-devel for package: krb5-devel-1.15.1-34.el7.x86_64
--> Processing Dependency: libselinux-devel for package: krb5-devel-1.15.1-34.el7.x86_64
--> Processing Dependency: keyutils-libs-devel for package: krb5-devel-1.15.1-34.el7.x86_64
---> Package openssl-devel.x86_64 1:1.0.2k-16.el7 will be installed
--> Processing Dependency: openssl-libs(x86-64) = 1:1.0.2k-16.el7 for package: 1:openssl-devel-1.0.2k-16.el7.x86_64
--> Running transaction check
---> Package keyutils-libs-devel.x86_64 0:1.5.8-3.el7 will be installed
---> Package krb5-devel.x86_64 0:1.15.1-34.el7 will be installed
--> Processing Dependency: krb5-libs(x86-64) = 1.15.1-34.el7 for package: krb5-devel-1.15.1-34.el7.x86_64
---> Package libkadm5.x86_64 0:1.15.1-34.el7 will be installed
--> Processing Dependency: krb5-libs(x86-64) = 1.15.1-34.el7 for package: libkadm5-1.15.1-34.el7.x86_64
---> Package libselinux-devel.x86_64 0:2.5-14.1.el7 will be installed
--> Processing Dependency: libsepol-devel(x86-64) >= 2.5-10 for package: libselinux-devel-2.5-14.1.el7.x86_64
--> Processing Dependency: pkgconfig(libsepol) for package: libselinux-devel-2.5-14.1.el7.x86_64
--> Processing Dependency: pkgconfig(libpcre) for package: libselinux-devel-2.5-14.1.el7.x86_64
---> Package libverto-devel.x86_64 0:0.2.5-4.el7 will be installed
---> Package openssl-devel.x86_64 1:1.0.2k-16.el7 will be installed
--> Processing Dependency: openssl-libs(x86-64) = 1:1.0.2k-16.el7 for package: 1:openssl-devel-1.0.2k-16.el7.x86_64
--> Running transaction check
---> Package krb5-devel.x86_64 0:1.15.1-34.el7 will be installed
--> Processing Dependency: krb5-libs(x86-64) = 1.15.1-34.el7 for package: krb5-devel-1.15.1-34.el7.x86_64
---> Package libkadm5.x86_64 0:1.15.1-34.el7 will be installed
--> Processing Dependency: krb5-libs(x86-64) = 1.15.1-34.el7 for package: libkadm5-1.15.1-34.el7.x86_64
---> Package libsepol-devel.x86_64 0:2.5-10.el7 will be installed
---> Package openssl-devel.x86_64 1:1.0.2k-16.el7 will be installed
--> Processing Dependency: openssl-libs(x86-64) = 1:1.0.2k-16.el7 for package: 1:openssl-devel-1.0.2k-16.el7.x86_64
---> Package pcre-devel.x86_64 0:8.32-17.el7 will be installed
--> Finished Dependency Resolution
Error: Package: 1:openssl-devel-1.0.2k-16.el7.x86_64 (local-media)
           Requires: openssl-libs(x86-64) = 1:1.0.2k-16.el7
           Installed: 1:openssl-libs-1.0.2k-16.el7_6.1.x86_64 (@updates)
               openssl-libs(x86-64) = 1:1.0.2k-16.el7_6.1
           Available: 1:openssl-libs-1.0.2k-16.el7.x86_64 (local-media)
               openssl-libs(x86-64) = 1:1.0.2k-16.el7
Error: Package: libkadm5-1.15.1-34.el7.x86_64 (local-media)
           Requires: krb5-libs(x86-64) = 1.15.1-34.el7
           Installed: krb5-libs-1.15.1-37.el7_6.x86_64 (@updates)
               krb5-libs(x86-64) = 1.15.1-37.el7_6
           Available: krb5-libs-1.15.1-34.el7.x86_64 (local-media)
               krb5-libs(x86-64) = 1.15.1-34.el7
Error: Package: krb5-devel-1.15.1-34.el7.x86_64 (local-media)
           Requires: krb5-libs(x86-64) = 1.15.1-34.el7
           Installed: krb5-libs-1.15.1-37.el7_6.x86_64 (@updates)
               krb5-libs(x86-64) = 1.15.1-37.el7_6
           Available: krb5-libs-1.15.1-34.el7.x86_64 (local-media)
               krb5-libs(x86-64) = 1.15.1-34.el7
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

可以尝试执行
yum clean all
yum distro-sync
后再尝试执行
yum install openssl-devel 看是否可以正常安装,如果可以正常安装就可以重新安装lnmp
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2022-2-24 15:16:00 | 显示全部楼层

licess 发表于 2022-2-24 12:08
可以尝试执行
yum clean all
yum distro-sync

厉害啊,执行了这两个后lnmp环境就安装成功啦,谢谢大佬帮忙

那我理解应该就是没装 openssl-devel 这个依赖包了

不过下面这里出错是不是主要用在在线安装的情况下的呢,我看它尝试去那个 soft.vpser.net (soft.vpser.net)... 81.70.180.148 节点,但是失败了。



[PEAR] XML_Util       - installed: 1.4.5
warning: pear/PEAR dependency package "pear/Archive_Tar" installed version 1.4.9 is not the recommended version 1.4.4
[PEAR] PEAR           - installed: 1.10.12
Wrote PEAR system config file at: /usr/local/php/etc/pear.conf
You may want to add: /usr/local/php/lib/php to your php.ini include_path
/home/lnmp1.7-full/src/php-7.3.23/build/shtool install -c ext/phar/phar.phar /usr/local/php/bin
ln -s -f phar.phar /usr/local/php/bin/phar
Installing PDO headers:           /usr/local/php/include/php/ext/pdo/
Copy new php configure file...
Modify php.ini......
config-set succeeded
config-set succeeded
Downloading Composer...
--2022-02-24 14:56:10--  https://soft.vpser.net/web/php/composer/composer.phar
Resolving soft.vpser.net (soft.vpser.net)... 81.70.180.148
Connecting to soft.vpser.net (soft.vpser.net)|81.70.180.148|:443... failed: Connection timed out.
Retrying.

--2022-02-24 14:58:11--  (try: 2)  https://soft.vpser.net/web/php/composer/composer.phar
Connecting to soft.vpser.net (soft.vpser.net)|81.70.180.148|:443... failed: Connection timed out.
Retrying.

--2022-02-24 15:00:13--  (try: 3)  https://soft.vpser.net/web/php/composer/composer.phar
Connecting to soft.vpser.net (soft.vpser.net)|81.70.180.148|:443... ^[[Bfailed: Connection timed out.
Giving up.

Composer install failed, try to from composer official website...



美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

发表于 2022-2-24 18:26:24 | 显示全部楼层



一岁呀 发表于 2022-2-24 15:16
厉害啊,执行了这两个后lnmp环境就安装成功啦,谢谢大佬帮忙

那我理解应该就是没装 openssl-devel 这个 ...

composer使用的话需要联网环境,内网环境无法下载是正常的
 楼主| 发表于 2022-2-25 10:00:13 | 显示全部楼层

licess 发表于 2022-2-24 18:26
composer使用的话需要联网环境,内网环境无法下载是正常的

难怪我装的时候这里等了很久,但是最后是成功了,就很神奇。
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2022-5-27 20:22 , Processed in 0.023866 second(s), 17 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表