VPS侦探论坛

 找回密码
 注册
查看: 637|回复: 3

CVE-2021-21703漏洞怎么修,军哥

[复制链接]
发表于 2022-3-15 09:44:54 | 显示全部楼层 |阅读模式

军哥,今天检测出,有CVE-2021-21703这个漏洞。
https://bugs.php.net/bug.php?id=81026

现在用lnmp1.7 和 lnmp1.8,php5.6 和 php7.3,怎么修复这个问题呢?
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2022-3-15 10:25:49 | 显示全部楼层




军哥,如下步骤可以升级吗?或者其它方式?

1. 下载好,
fpm_scoreboard_proc_oob_fix_v4.patch
放到 src/patch 目录下。

2. 修改 vim upgrade_php.sh
patch -p1 < ${cur_dir}/src/patch/php-5.2.17-max-input-vars.patch
patch -p0 < ${cur_dir}/src/patch/php-5.2.17-xml.patch
patch -p1 < ${cur_dir}/src/patch/debian_patches_disable_SSLv2_for_openssl_1_0_0.patch

patch -p1 < ${cur_dir}/src/patch/php-5.2-multipart-form-data.patch在这个地方添加如下
patch -p1 < ${cur_dir}/src/patch/fpm_scoreboard_proc_oob_fix_v4.patch


3. 然后
upgarde.sh
升级PHP

Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
发表于 2022-3-15 13:38:48 | 显示全部楼层

PHP 7.3.32+ 这个bug是修复了的,如果PHP已经是7.3.32+版本的话肯定修复了的,PHP 7.2及以下应该是都没有修复的,不过这种bug利用方法一般也都比较苛刻
PHP 5.6早就停止更新了,patch很有可能没法直接用在PHP 5.6上,你可以要修复只能自己按patch修改代码

升级脚本中不同版本PHP对应的都是不同版本的升级脚本
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2022-4-15 09:52:32 | 显示全部楼层



bin 发表于 2022-3-15 10:25
军哥,如下步骤可以升级吗?或者其它方式?

1. 下载好,

最后怎么解决的呀
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2022-5-24 01:07 , Processed in 0.030109 second(s), 16 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表