VPS侦探论坛

 找回密码
 注册
查看: 292|回复: 1

CentOS 7.6 内网离线安装LNMP1.8失败

[复制链接]
发表于 2022-3-23 02:06:13 | 显示全部楼层 |阅读模式

系统版本:CentOS Linux release 7.6.1810 (Core)

安装环境要求:php7.2、mysql5.7

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有账号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2022-3-23 09:24:02 | 显示全部楼层


Loading mirror speeds from cached hostfile
Resolving Dependencies
--> Running transaction check
---> Package gcc-c++.x86_64 0:4.8.5-36.el7 will be installed
--> Processing Dependency: libstdc++-devel = 4.8.5-36.el7 for package: gcc-c++-4.8.5-36.el7.x86_64
--> Processing Dependency: libstdc++ = 4.8.5-36.el7 for package: gcc-c++-4.8.5-36.el7.x86_64
--> Processing Dependency: gcc = 4.8.5-36.el7 for package: gcc-c++-4.8.5-36.el7.x86_64
--> Running transaction check
---> Package gcc-c++.x86_64 0:4.8.5-36.el7 will be installed
--> Processing Dependency: gcc = 4.8.5-36.el7 for package: gcc-c++-4.8.5-36.el7.x86_64
---> Package libstdc++.i686 0:4.8.5-36.el7 will be installed
--> Processing Dependency: libm.so.6(GLIBC_2.0) for package: libstdc++-4.8.5-36.el7.i686
--> Processing Dependency: libm.so.6 for package: libstdc++-4.8.5-36.el7.i686
--> Processing Dependency: libgcc_s.so.1(GLIBC_2.0) for package: libstdc++-4.8.5-36.el7.i686
--> Processing Dependency: libgcc_s.so.1(GCC_4.2.0) for package: libstdc++-4.8.5-36.el7.i686
--> Processing Dependency: libgcc_s.so.1(GCC_3.3) for package: libstdc++-4.8.5-36.el7.i686
--> Processing Dependency: libgcc_s.so.1(GCC_3.0) for package: libstdc++-4.8.5-36.el7.i686
--> Processing Dependency: libgcc_s.so.1 for package: libstdc++-4.8.5-36.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: libstdc++-4.8.5-36.el7.i686
--> Processing Dependency: ld-linux.so.2(GLIBC_2.3) for package: libstdc++-4.8.5-36.el7.i686
--> Processing Dependency: ld-linux.so.2 for package: libstdc++-4.8.5-36.el7.i686
---> Package libstdc++-devel.x86_64 0:4.8.5-36.el7 will be installed
--> Processing Dependency: libstdc++(x86-64) = 4.8.5-36.el7 for package: libstdc++-devel-4.8.5-36.el7.x86_64
--> Running transaction check
---> Package gcc-c++.x86_64 0:4.8.5-36.el7 will be installed
--> Processing Dependency: gcc = 4.8.5-36.el7 for package: gcc-c++-4.8.5-36.el7.x86_64
---> Package glibc.i686 0:2.17-260.el7 will be installed
--> Processing Dependency: glibc-common = 2.17-260.el7 for package: glibc-2.17-260.el7.i686
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.17-260.el7.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.17-260.el7.i686
---> Package libgcc.i686 0:4.8.5-36.el7 will be installed
---> Package libstdc++-devel.x86_64 0:4.8.5-36.el7 will be installed
--> Processing Dependency: libstdc++(x86-64) = 4.8.5-36.el7 for package: libstdc++-devel-4.8.5-36.el7.x86_64
--> Running transaction check
---> Package gcc-c++.x86_64 0:4.8.5-36.el7 will be installed
--> Processing Dependency: gcc = 4.8.5-36.el7 for package: gcc-c++-4.8.5-36.el7.x86_64
---> Package glibc.i686 0:2.17-260.el7 will be installed
--> Processing Dependency: glibc-common = 2.17-260.el7 for package: glibc-2.17-260.el7.i686
---> Package libstdc++-devel.x86_64 0:4.8.5-36.el7 will be installed
--> Processing Dependency: libstdc++(x86-64) = 4.8.5-36.el7 for package: libstdc++-devel-4.8.5-36.el7.x86_64
---> Package nss-softokn-freebl.i686 0:3.36.0-5.el7_5 will be installed
--> Finished Dependency Resolution
Error: Package: libstdc++-devel-4.8.5-36.el7.x86_64 (local-media)
           Requires: libstdc++(x86-64) = 4.8.5-36.el7
           Installed: libstdc++-4.8.5-36.el7_6.2.x86_64 (@updates)
               libstdc++(x86-64) = 4.8.5-36.el7_6.2
           Available: libstdc++-4.8.5-36.el7.x86_64 (local-media)
               libstdc++(x86-64) = 4.8.5-36.el7
Error: Package: gcc-c++-4.8.5-36.el7.x86_64 (local-media)
           Requires: gcc = 4.8.5-36.el7
           Installed: gcc-4.8.5-36.el7_6.2.x86_64 (@updates)
               gcc = 4.8.2-16.el7_6
               gcc = 4.8.5-36.el7_6.2
           Available: gcc-4.8.5-36.el7.x86_64 (local-media)
               gcc = 4.8.5-36.el7
               gcc = 4.8.2-16.el7
Error: Package: glibc-2.17-260.el7.i686 (local-media)
           Requires: glibc-common = 2.17-260.el7
           Installed: glibc-common-2.17-260.el7_6.6.x86_64 (@updates)
               glibc-common = 2.17-260.el7_6.6
           Available: glibc-common-2.17-260.el7.x86_64 (local-media)
               glibc-common = 2.17-260.el7
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

可能因为你这机器之前联网安装过一些软件导致的
执行:yum distro-sync
成功后,再执行:yum install gcc-c++ 试试
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2022-5-27 19:49 , Processed in 0.018527 second(s), 18 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表