VPS侦探论坛

 找回密码
 注册
查看: 320|回复: 5

求助:lnmp1.8-full 内网离线安装失败

[复制链接]
发表于 2022-4-6 11:22:59 | 显示全部楼层 |阅读模式

这个步骤操作下来,最后安装失败,请军哥帮忙看下原因


Press any key to install...or Press Ctrl+c to cancel

You will install lnmp stack.
nginx-1.20.1
mysql-5.7.34
php-7.3.29
Enable InnoDB: y
Print lnmp.conf infomation...
Download Mirror: https://soft.vpser.net
Nginx Additional Modules:
PHP Additional Modules:
Database Directory: /usr/local/mysql/var
Default Website Directory: /home/wwwroot/default
LNMP Version: 1.8
CentOS 7
\S
Kernel \r on an \m

CentOS Linux release 7.5.1804 (Core)
NAME="CentOS Linux"
VERSION="7 (Core)"
ID="centos"
ID_LIKE="rhel fedora"
VERSION_ID="7"
PRETTY_NAME="CentOS Linux 7 (Core)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:centos:centos:7"
HOME_URL="https://www.centos.org/"
BUG_REPORT_URL="https://bugs.centos.org/"

CENTOS_MANTISBT_PROJECT="CentOS-7"
CENTOS_MANTISBT_PROJECT_VERSION="7"
REDHAT_SUPPORT_PRODUCT="centos"
REDHAT_SUPPORT_PRODUCT_VERSION="7"

CentOS Linux release 7.5.1804 (Core)
CentOS Linux release 7.5.1804 (Core)
Linux iZf4o01zcmr4ucorfkc068Z 3.10.0-862.14.4.el7.x86_64 #1 SMP Wed Sep 26 15:12:11 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
Memory is: 3789 MB
Filesystem      Size  Used Avail Use% Mounted on
/dev/vda1        99G   17G   77G  18% /
devtmpfs        1.9G     0  1.9G   0% /dev
tmpfs           1.9G     0  1.9G   0% /dev/shm
tmpfs           1.9G  504K  1.9G   1% /run
tmpfs           1.9G     0  1.9G   0% /sys/fs/cgroup
tmpfs           379M     0  379M   0% /run/user/0
/dev/loop0      8.8G  8.8G     0 100% /mnt/dvd
OpenSSL 1.0.2k-fips  26 Jan 2017
Hosts: ok.
PING lnmp.org (168.235.75.115) 56(84) bytes of data.

--- lnmp.org ping statistics ---
1 packets transmitted, 0 received, 100% packet loss, time 0ms
DNS...ok
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
No package python3 available.
Error: Nothing to do
Setting timezone...
Wed Apr  6 10:58:56 CST 2022
[-] Yum remove packages...
error: package httpd is not installed
error: package httpd-tools is not installed
Loaded plugins: fastestmirror
No Match for argument: mysql-server
No Match for argument: mysql
No Match for argument: mysql-libs
No Match for argument: mariadb-server
No Match for argument: mariadb
No Match for argument: mariadb-libs
No Packages marked for removal
error: package mysql is not installed
error: package mysql-libs is not installed
error: package mariadb is not installed
error: package mariadb-libs is not installed
error: package php-mysql is not installed
error: package php-cli is not installed
error: package php-gd is not installed
error: package php-common is not installed
error: package php is not installed
Loaded plugins: fastestmirror
No Match for argument: httpd*
No Packages marked for removal
Loaded plugins: fastestmirror
No Match for argument: php*
No Packages marked for removal
Loaded plugins: fastestmirror
Cleaning repos: local-media
Cleaning up everything
Maybe you want: rm -rf /var/cache/yum, to also free up space taken by orphaned data from disabled or removed repos
Cleaning up list of fastest mirrors
[+] Yum installing dependent packages...
Loaded plugins: fastestmirror
Determining fastest mirrors
Package 1:make-3.82-23.el7.x86_64 already installed and latest version
Nothing to do
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Resolving Dependencies
--> Running transaction check
---> Package cmake.x86_64 0:2.8.12.2-2.el7 will be installed
--> Processing Dependency: libarchive.so.13()(64bit) for package: cmake-2.8.12.2-2.el7.x86_64
--> Running transaction check
---> Package libarchive.x86_64 0:3.1.2-10.el7_2 will be installed
--> Finished Dependency Resolution

Dependencies Resolved


Create PHP Info Tool...
Copy PHP Prober...
Copy Opcache Control Panel...
============================Install PHPMyAdmin=================================
============================phpMyAdmin install completed=======================
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Resolving Dependencies
--> Running transaction check
---> Package iptables-services.x86_64 0:1.4.21-24.el7 will be installed
--> Processing Dependency: iptables = 1.4.21-24.el7 for package: iptables-services-1.4.21-24.el7.x86_64
--> Running transaction check
---> Package iptables.i686 0:1.4.21-24.el7 will be installed
--> Processing Dependency: libnfnetlink.so.0 for package: iptables-1.4.21-24.el7.i686
--> Processing Dependency: libnetfilter_conntrack.so.3 for package: iptables-1.4.21-24.el7.i686
--> Processing Dependency: libm.so.6(GLIBC_2.1) for package: iptables-1.4.21-24.el7.i686
--> Processing Dependency: libm.so.6(GLIBC_2.0) for package: iptables-1.4.21-24.el7.i686
--> Processing Dependency: libm.so.6 for package: iptables-1.4.21-24.el7.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.1) for package: iptables-1.4.21-24.el7.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.0) for package: iptables-1.4.21-24.el7.i686
--> Processing Dependency: libdl.so.2 for package: iptables-1.4.21-24.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.7) for package: iptables-1.4.21-24.el7.i686
--> Running transaction check
---> Package glibc.i686 0:2.17-222.el7 will be installed
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.17-222.el7.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.17-222.el7.i686
---> Package libnetfilter_conntrack.i686 0:1.0.6-1.el7_3 will be installed
--> Processing Dependency: libmnl.so.0(LIBMNL_1.1) for package: libnetfilter_conntrack-1.0.6-1.el7_3.i686
--> Processing Dependency: libmnl.so.0(LIBMNL_1.0) for package: libnetfilter_conntrack-1.0.6-1.el7_3.i686
--> Processing Dependency: libmnl.so.0 for package: libnetfilter_conntrack-1.0.6-1.el7_3.i686
---> Package libnfnetlink.i686 0:1.0.1-4.el7 will be installed
--> Running transaction check
---> Package libmnl.i686 0:1.0.3-7.el7 will be installed
---> Package nss-softokn-freebl.i686 0:3.34.0-2.el7 will be installed
--> Finished Dependency Resolution
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:

         1. You have an upgrade for iptables which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of iptables of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude iptables.otherarch ... this should give you an error
            message showing the root cause of the problem.

         2. You have multiple architectures of iptables installed, but
            yum can only see an upgrade for one of those architectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.

         3. You have duplicate versions of iptables installed already.
            You can use "yum check" to get yum show these errors.

       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).

       Protected multilib versions: iptables-1.4.21-24.el7.i686 != iptables-1.4.21-24.1.el7_5.x86_64
Error: Protected multilib versions: nss-softokn-freebl-3.34.0-2.el7.i686 != nss-softokn-freebl-3.36.0-5.el7_5.x86_64
The service command supports only basic LSB actions (start, stop, restart, try-restart, reload, force-reload, status). For other actions, please try to use systemctl.
Redirecting to /bin/systemctl reload iptables.service
Failed to reload iptables.service: Unit not found.
Add iptables service at system startup...
error reading information on service iptables: No such file or directory
error reading information on service iptables: No such file or directory
Add Startup and Starting LNMP...
Add nginx service at system startup...
Created symlink from /etc/systemd/system/multi-user.target.wants/nginx.service to /etc/systemd/system/nginx.service.
Add mysql service at system startup...
Job for mysql.service failed because the control process exited with error code. See "systemctl status mysql.service" and "journalctl -xe" for details.
Add php-fpm service at system startup...
Created symlink from /etc/systemd/system/multi-user.target.wants/php-fpm.service to /etc/systemd/system/php-fpm.service.
============================== Check install ==============================
Checking ...
Nginx: OK
Error: MySQL install failed.
Error: PHP install failed.
Sorry, Failed to install LNMP!
Please visit https://bbs.vpser.net/forum-25-1.html feedback errors and logs.
You can download /root/lnmp-install.log from your server,and upload lnmp-install.log to LNMP Forum.


美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2022-4-6 11:24:50 | 显示全部楼层


系统:CentOS Linux release 7.5.1804 (Core)
下载的光盘镜像:CentOS-7-x86_64-Everything-1804.iso

用这个安装命令:CheckMirror=n ./install.sh lnmp
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2022-4-6 11:48:09 | 显示全部楼层

刚才日志上传不了,补充一下

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有账号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2022-4-6 15:56:25 | 显示全部楼层



日志仅贴出了少部分,无法完全判断仅按贴出的错误看的话参考: https://bbs.vpser.net/thread-25381-1-1.html
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2022-4-6 16:18:55 | 显示全部楼层

licess 发表于 2022-4-6 15:56
日志仅贴出了少部分,无法完全判断仅按贴出的错误看的话参考: https://bbs.vpser.net/thread-25381-1-1.ht ...

老大,在3楼。发帖的时候上传不了,后来补上了

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

发表于 2022-4-6 20:12:14 | 显示全部楼层

hzhdll 发表于 2022-4-6 16:18
老大,在3楼。发帖的时候上传不了,后来补上了

看日志还有另外一个错误
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Package matching gcc-4.8.5-28.el7.x86_64 already installed. Checking for update.
Nothing to do
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Resolving Dependencies
--> Running transaction check
---> Package gcc-c++.x86_64 0:4.8.5-28.el7 will be installed
--> Processing Dependency: libstdc++-devel = 4.8.5-28.el7 for package: gcc-c++-4.8.5-28.el7.x86_64
--> Processing Dependency: libstdc++ = 4.8.5-28.el7 for package: gcc-c++-4.8.5-28.el7.x86_64
--> Processing Dependency: gcc = 4.8.5-28.el7 for package: gcc-c++-4.8.5-28.el7.x86_64
--> Running transaction check
---> Package gcc-c++.x86_64 0:4.8.5-28.el7 will be installed
--> Processing Dependency: gcc = 4.8.5-28.el7 for package: gcc-c++-4.8.5-28.el7.x86_64
---> Package libstdc++.i686 0:4.8.5-28.el7 will be installed
--> Processing Dependency: libm.so.6(GLIBC_2.0) for package: libstdc++-4.8.5-28.el7.i686
--> Processing Dependency: libm.so.6 for package: libstdc++-4.8.5-28.el7.i686
--> Processing Dependency: libgcc_s.so.1(GLIBC_2.0) for package: libstdc++-4.8.5-28.el7.i686
--> Processing Dependency: libgcc_s.so.1(GCC_4.2.0) for package: libstdc++-4.8.5-28.el7.i686
--> Processing Dependency: libgcc_s.so.1(GCC_3.3) for package: libstdc++-4.8.5-28.el7.i686
--> Processing Dependency: libgcc_s.so.1(GCC_3.0) for package: libstdc++-4.8.5-28.el7.i686
--> Processing Dependency: libgcc_s.so.1 for package: libstdc++-4.8.5-28.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: libstdc++-4.8.5-28.el7.i686
--> Processing Dependency: ld-linux.so.2(GLIBC_2.3) for package: libstdc++-4.8.5-28.el7.i686
--> Processing Dependency: ld-linux.so.2 for package: libstdc++-4.8.5-28.el7.i686
---> Package libstdc++-devel.x86_64 0:4.8.5-28.el7 will be installed
--> Processing Dependency: libstdc++(x86-64) = 4.8.5-28.el7 for package: libstdc++-devel-4.8.5-28.el7.x86_64
--> Running transaction check
---> Package gcc-c++.x86_64 0:4.8.5-28.el7 will be installed
--> Processing Dependency: gcc = 4.8.5-28.el7 for package: gcc-c++-4.8.5-28.el7.x86_64
---> Package glibc.i686 0:2.17-222.el7 will be installed
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.17-222.el7.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.17-222.el7.i686
---> Package libgcc.i686 0:4.8.5-28.el7 will be installed
---> Package libstdc++-devel.x86_64 0:4.8.5-28.el7 will be installed
--> Processing Dependency: libstdc++(x86-64) = 4.8.5-28.el7 for package: libstdc++-devel-4.8.5-28.el7.x86_64
--> Running transaction check
---> Package gcc-c++.x86_64 0:4.8.5-28.el7 will be installed
--> Processing Dependency: gcc = 4.8.5-28.el7 for package: gcc-c++-4.8.5-28.el7.x86_64
---> Package libstdc++-devel.x86_64 0:4.8.5-28.el7 will be installed
--> Processing Dependency: libstdc++(x86-64) = 4.8.5-28.el7 for package: libstdc++-devel-4.8.5-28.el7.x86_64
---> Package nss-softokn-freebl.i686 0:3.34.0-2.el7 will be installed
--> Finished Dependency Resolution
Error: Package: libstdc++-devel-4.8.5-28.el7.x86_64 (local-media)
           Requires: libstdc++(x86-64) = 4.8.5-28.el7
           Installed: libstdc++-4.8.5-28.el7_5.1.x86_64 (@updates)
               libstdc++(x86-64) = 4.8.5-28.el7_5.1
           Available: libstdc++-4.8.5-28.el7.x86_64 (local-media)
               libstdc++(x86-64) = 4.8.5-28.el7
Error: Package: gcc-c++-4.8.5-28.el7.x86_64 (local-media)
           Requires: gcc = 4.8.5-28.el7
           Installed: gcc-4.8.5-28.el7_5.1.x86_64 (@updates)
               gcc = 4.8.2-16.el7_5
               gcc = 4.8.5-28.el7_5.1
           Available: gcc-4.8.5-28.el7.x86_64 (local-media)
               gcc = 4.8.5-28.el7
               gcc = 4.8.2-16.el7
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

参考:https://bbs.vpser.net/thread-26066-1-1.html
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2022-5-27 20:28 , Processed in 0.019955 second(s), 17 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表