VPS侦探论坛

 找回密码
 注册
查看: 179|回复: 9

Kylin Advanced Linux Server

[复制链接]
发表于 2022-5-5 14:55:09 | 显示全部楼层 |阅读模式

请问,关于麒麟服务器操作系统的最新版本已经发布了吗?在麒麟最新的服务器上安装1.9,提示Unable to get Linux distribution name, or do NOT support the current distribution.
请问,关于这个问题是否已经解决?
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2022-5-5 15:16:42 | 显示全部楼层


已经在main.sh中添加
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
发表于 2022-5-5 19:41:52 | 显示全部楼层

lnmp 1.9早已经支持了Kylin Linux Advanced Server
验证一下安装包md5是否和官网一样
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2022-5-7 09:28:52 | 显示全部楼层



安装1.9版本在麒麟服务器操作系统SP2上,总是php安装失败。请问可否跳过次安装?或者有没有办法修复php安装的问题?
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2022-5-7 11:14:58 | 显示全部楼层

本帖最后由 glen 于 2022-5-7 11:17 编辑

系统:银河麒麟高级服务器操作系统V10-SP2 架构:x86  内存:8G  

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

 楼主| 发表于 2022-5-7 11:21:20 | 显示全部楼层

You will install lnmp stack.
nginx-1.20.2
mysql-5.7.34
php-5.6.40
Enable InnoDB: y
Print lnmp.conf infomation...
Download Mirror: https://soft.vpser.net
Nginx Additional Modules:
PHP Additional Modules:
Database Directory: /usr/local/mysql/var
Default Website Directory: /home/wwwroot/default
LNMP Version: 1.9
Kylin V10                                                                                                                                                                                                                                                                                                                                                                     
chown: 正在更改'/home/wwwroot/default/.user.ini' 的所有者: 不允许的操作
mkdir: 无法创建目录 “/usr/local/nginx/conf/vhost”: 文件已存在
include/nginx.sh:行145: /home/wwwroot/default/.user.ini: 不允许的操作
chmod: 正在更改 '/home/wwwroot/default/.user.ini' 的权限: 不允许的操作
3.9+
Create PHP Info Tool...
Copy PHP Prober...
Copy Opcache Control Panel...
============================Install PHPMyAdmin=================================
============================phpMyAdmin install completed=======================
上次元数据过期检查:0:23:02 前,执行于 2022年05月07日 星期六 10时39分43秒。
软件包 iptables-1.8.5-2.ky10.x86_64 已安装。
依赖关系解决。
无需任何处理。
完毕!
iptables: Saving firewall rules to /etc/sysconfig/iptables: [  OK  ]
重定向至 /bin/systemctl reload iptables.service
Add iptables service at system startup...
Add Startup and Starting LNMP...
Add nginx service at system startup...
Synchronizing state of nginx.service with SysV service script with /usr/lib/systemd/systemd-sysv-install.
Executing: /usr/lib/systemd/systemd-sysv-install enable nginx
Add mysql service at system startup...
Synchronizing state of mysql.service with SysV service script with /usr/lib/systemd/systemd-sysv-install.
Executing: /usr/lib/systemd/systemd-sysv-install enable mysql
Add php-fpm service at system startup...
Synchronizing state of php-fpm.service with SysV service script with /usr/lib/systemd/systemd-sysv-install.
Executing: /usr/lib/systemd/systemd-sysv-install enable php-fpm
 楼主| 发表于 2022-5-7 11:25:27 | 显示全部楼层

直接通过安装lnmp中的php 5.6的bz2包是可以直接安装上的。可是,使用一键安装包却无法安装。

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有账号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2022-5-7 13:41:39 | 显示全部楼层

glen 发表于 2022-5-7 09:28
安装1.9版本在麒麟服务器操作系统SP2上,总是php安装失败。请问可否跳过次安装?或者有没有办法修复php安装 ...

低版本php肯定是无法在这么新的系统上无法安装的,Kylin Linux Advanced Server V10 SP2 自带icu依赖版本比centos stream 8 都高一截,你安装上应该是没加intl模块的
没有日志没法分析原因,分析原因按反馈必读要求提供信息
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2022-5-7 16:45:24 | 显示全部楼层


链接:https://pan.baidu.com/s/1ZyvyMXKpwVjQyPidScrW_g
提取码:fqtq                     
不好意思,上面是两次安装的日志。
                                                                                                                                                                                                                        
美国VPS推荐: 遨游主机LinodeLOCVPSKVMLAVPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2022-5-8 09:37:39 | 显示全部楼层



glen 发表于 2022-5-7 16:45
链接:https://pan.baidu.com/s/1ZyvyMXKpwVjQyPidScrW_g
提取码:fqtq                     
不好意思, ...
/root/lnmp1.9/src/php-5.6.40/ext/intl/intl_convertcpp.cpp:74:31: 错误:对成员‘getBuffer’的请求出现在‘from’中,而后者具有非类类型‘const int’
  const UChar *utf16buf = from.getBuffer();
                               ^~~~~~~~~
/root/lnmp1.9/src/php-5.6.40/ext/intl/intl_convertcpp.cpp:76:69: 错误:对成员‘length’的请求出现在‘from’中,而后者具有非类类型‘const int’
  u_strToUTF8WithSub(*res, capacity - 1, &actual_len, utf16buf, from.length(),
                                                                     ^~~~~~
make: *** [Makefile:964:ext/intl/intl_convertcpp.lo] 错误 1

这个就是8楼说的icu问题
另外一个php8.0的都没安装完发日志也没用
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2022-5-22 18:27 , Processed in 0.021519 second(s), 17 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表