VPS侦探论坛

 找回密码
 注册
查看: 206|回复: 2

政务网安装失败

[复制链接]
发表于 2022-6-5 17:49:49 | 显示全部楼层 |阅读模式

安装日志在附件中.

离线安装

服务器版本:
CentOS-7-x86_64-2003

安装的软件有:
php7.4
mysql 5.6
nginx 1.8

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有账号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPS主机云VPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2022-6-5 17:50:57 | 显示全部楼层


政务网不能链接互联网,只能选择离线安装, 目前只有nginx安装成功
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
发表于 2022-6-6 19:58:20 | 显示全部楼层

---> Package libgcc.i686 0:4.8.5-39.el7 will be installed
---> Package libstdc++.i686 0:4.8.5-39.el7 will be installed
---> Package ncurses-libs.i686 0:5.9-14.20130511.el7_4 will be installed
---> Package readline.i686 0:6.2-11.el7 will be installed
--> Finished Dependency Resolution
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:
      
         1. You have an upgrade for libcurl which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of libcurl of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude libcurl.otherarch ... this should give you an error
            message showing the root cause of the problem.
      
         2. You have multiple architectures of libcurl installed, but
            yum can only see an upgrade for one of those architectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.
      
         3. You have duplicate versions of libcurl installed already.
            You can use "yum check" to get yum show these errors.
      
       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).
      
       Protected multilib versions: libcurl-7.29.0-57.el7.i686 != libcurl-7.29.0-57.el7_8.1.x86_64


。。。。。。。
Loading mirror speeds from cached hostfile
Resolving Dependencies
--> Running transaction check
---> Package libicu-devel.x86_64 0:50.2-3.el7 will be installed
--> Processing Dependency: libicu(x86-64) = 50.2-3.el7 for package: libicu-devel-50.2-3.el7.x86_64
--> Finished Dependency Resolution
Error: Package: libicu-devel-50.2-3.el7.x86_64 (local-media)
           Requires: libicu(x86-64) = 50.2-3.el7
           Installed: libicu-50.2-4.el7_7.x86_64 (@updates)
               libicu(x86-64) = 50.2-4.el7_7
           Available: libicu-50.2-3.el7.x86_64 (local-media)
               libicu(x86-64) = 50.2-3.el7
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
。。。。。。
--2022-06-05 17:32:05--  https://cdn.mysql.com/Downloads/ ... c2.12-x86_64.tar.gz
Resolving cdn.mysql.com (cdn.mysql.com)... failed: Name or service not known.
wget: unable to resolve host address ‘cdn.mysql.com’

系统上有问题,可以参考:https://bbs.vpser.net/thread-25932-1-1.html
另外full包里面是不包含MySQL 5.7、8.0的二进制安装包的,这个在下载页面上有说明,要用二进制安装需要提前下载并放到 src 目录下。
美国VPS推荐: 遨游主机LinodeLOCVPS主机云VPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2022-7-6 14:48 , Processed in 0.022572 second(s), 17 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表