VPS侦探论坛

 找回密码
 注册
查看: 131|回复: 5

LNMP1.8安装5.3,然后多版本再安装5.4出错

[复制链接]
发表于 2022-6-16 21:56:37 | 显示全部楼层 |阅读模式

本帖最后由 onephp 于 2022-6-16 22:05 编辑

因为项目比较陈旧,下载的LNMP1.8版本。系统环境为Ubuntu20。

军哥虽然您已经提示Ubuntu不能安装低版本,但是我把限制去掉了,php5.3也能正常运行。这完全是因为客户机器必须是Ubuntu20,不可更改。

麻烦军哥看一下,报错的信息应该是init.d.php-fpm这个文件最后没编译出来。

  1. Install ZendGuardLoader for PHP 5.4...
  2. Notice:  not found!!!download now...
  3. --2022-06-16 21:51:03--  https://soft.vpser.net/web/zend/ZendGuardLoader-70429-PHP-5.4-linux-glibc23-x86_64.tar.gz
  4. Resolving soft.vpser.net (soft.vpser.net)... 45.34.93.228, 2600:3c01::f03c:91ff:fe92:1a06
  5. Connecting to soft.vpser.net (soft.vpser.net)|45.34.93.228|:443... connected.
  6. HTTP request sent, awaiting response... 416 Requested Range Not Satisfiable

  7.     The file is already fully retrieved; nothing to do.

  8. Write ZendGuardLoader to php.ini...
  9. Creating new php-fpm configure file...
  10. Copy php-fpm init.d file...
  11. cp: cannot stat '/home/gxing/lnmp1.8-full/src/php-5.4.45/sapi/fpm/init.d.php-fpm': No such file or directory
  12. chmod: cannot access '/etc/init.d/php-fpm5.4': No such file or directory
  13. Add php-fpm5.4 service at system startup...
  14. +-------------------------------------------+
  15. |    Manager for LNMP, Written by Licess    |
  16. +-------------------------------------------+
  17. |              https://lnmp.org             |
  18. +-------------------------------------------+
  19. Starting LNMP...
  20. Starting nginx...  done
  21. Starting mysql (via systemctl): mysql.service.
  22. Starting php-fpm  done
  23. ^[[0;31mFailed to install php-5.4.45, you can download /root/install-mphp5.4.log from your server, and upload install-mphp5.4.log to LNMP Forum.
复制代码


美国VPS推荐: 遨游主机LinodeLOCVPS主机云VPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2022-6-17 10:18:49 | 显示全部楼层


php 5.3是不需要依赖icu的所以可以安装成功
php 5.4+默认都带intl模块,如果不需要intl模块,编辑 include/php.sh、include/multiplephp.sh、include/upgrade_php.sh 查找 --enable-intl 删掉对应php版本里面的 --enable-intl ,去掉intl模块的话应该是可以安装成功的
php 7.1及以下版本对比较新版本的linux发行版支持都或多或少有问题,虽然已经打了很多补丁了
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2022-6-16 22:06:39 | 显示全部楼层

日志文件在1楼,原文件名叫 mphp5.4.log

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有账号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPS主机云VPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2022-6-17 08:17:35 | 显示全部楼层



经过测试,无论是从php5.3升级到php5.4还是直接新安装lnmp里的php5.4,都是报这个错。
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2022-6-17 09:15:04 | 显示全部楼层

尝试安装了freetype-dev,现在/usr/local/php目录有了,以前连php目录也没有,但是里面只有etc目录。

发现新错误,但是ICU明明已经安装了:
  1. checking for icu-config... no
  2. checking for location of ICU headers and libraries... not found
  3. configure: error: Unable to detect ICU prefix or no failed. Please verify ICU install prefix and make sure icu-config works.
  4. make: *** No targets specified and no makefile found.  Stop.
  5. make: *** No targets specified and no makefile found.  Stop.
  6. make: *** No rule to make target 'install'.  Stop.
  7. Copy new php configure file...
  8. Modify php.ini......
  9. include/php.sh: line 86: pear: command not found
  10. include/php.sh: line 87: pecl: command not found
复制代码

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

 楼主| 发表于 2022-6-17 11:48:31 | 显示全部楼层

licess 发表于 2022-6-17 10:18
php 5.3是不需要依赖icu的所以可以安装成功
php 5.4+默认都带intl模块,如果不需要intl模块,编辑 include/ ...

军哥牛啊,手到病除。去掉了就编译成功了,这个问题我搜了SO上几乎没有,军哥一下解决了,太棒了。
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2022-7-6 18:10 , Processed in 0.035934 second(s), 18 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表