VPS侦探论坛

 找回密码
 注册
查看: 212|回复: 5

Ubuntu 22.04 ARM lnmp1.9 Mariadb安装失败 Could NOT find GnuTLS

[复制链接]
发表于 2022-6-28 15:09:43 | 显示全部楼层 |阅读模式

CMake Deprecation Warning at wsrep-lib/CMakeLists.txt:5 (cmake_minimum_required):
  Compatibility with CMake < 2.8.12 will be removed from a future version of
  CMake.

  Update the VERSION argument <min> value or use a ...<max> suffix to tell
  CMake that the project does not need compatibility with older versions.
....
CMake Error at /usr/share/cmake-3.22/Modules/FindPackageHandleStandardArgs.cmake:230 (message):
  Could NOT find GnuTLS (missing: GNUTLS_LIBRARY GNUTLS_INCLUDE_DIR)
  (Required is at least version "3.3.24")
Call Stack (most recent call first):
  /usr/share/cmake-3.22/Modules/FindPackageHandleStandardArgs.cmake:594 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/cmake-3.22/Modules/FindGnuTLS.cmake:68 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  libmariadb/CMakeLists.txt:331 (FIND_PACKAGE)


-- Configuring incomplete, errors occurred!
See also "/root/lnmp1.9/src/mariadb-10.6.8/CMakeFiles/CMakeOutput.log".
See also "/root/lnmp1.9/src/mariadb-10.6.8/CMakeFiles/CMakeError.log".
make: *** No targets specified and no makefile found.  Stop.
make: *** No targets specified and no makefile found.  Stop.
make: *** No rule to make target 'install'.  Stop.
include/mariadb.sh: line 585: /usr/local/mariadb/scripts/mysql_install_db: No such file or directory
cp: cannot stat 'support-files/mysql.server': No such file or directory
chmod: cannot access '/etc/init.d/mariadb': No such file or directory
Created symlink /etc/systemd/system/multi-user.target.wants/mariadb.service → /etc/systemd/system/mariadb.service.
Add mariadb service at system startup...
include/mariadb.sh: line 35: /etc/init.d/mariadb: No such file or directory
include/mariadb.sh: line 43: /etc/init.d/mariadb: No such file or directory
include/mariadb.sh: line 46: /usr/local/mariadb/bin/mysqladmin: No such file or directory
include/mariadb.sh: line 48: /etc/init.d/mariadb: No such file or directory
include/main.sh: line 849: /usr/local/mariadb/bin/mysql: No such file or directory
failed, try other way...
include/mariadb.sh: line 54: /etc/init.d/mariadb: No such file or directory
include/mariadb.sh: line 61: /usr/local/mariadb/bin/mysql: No such file or directory
Set password failed!
include/mariadb.sh: line 66: /usr/local/mariadb/bin/mysql: No such file or directory
FLUSH PRIVILEGES failed!
include/main.sh: line 849: /usr/local/mariadb/bin/mysql: No such file or directory
Update root password...
include/main.sh: line 849: /usr/local/mariadb/bin/mysql: No such file or directory
... Failed!
Remove anonymous users...
include/main.sh: line 849: /usr/local/mariadb/bin/mysql: No such file or directory
include/main.sh: line 849: /usr/local/mariadb/bin/mysql: No such file or directory
... Failed!
Disallow root login remotely...
include/main.sh: line 849: /usr/local/mariadb/bin/mysql: No such file or directory
... Failed!
Remove test database...
include/main.sh: line 849: /usr/local/mariadb/bin/mysql: No such file or directory
... Failed!
Reload privilege tables...
include/main.sh: line 849: /usr/local/mariadb/bin/mysql: No such file or directory
... Failed!
include/mariadb.sh: line 92: /etc/init.d/mariadb: No such file or directory
Clean database src directory...
Reading package lists...
Building dependency tree...
Reading state information...
libsasl2-dev is already the newest version (2.1.27+dfsg2-3ubuntu1).
The following additional packages will be installed:
  libldap-2.5-0 libldap-dev
sh: 0: getcwd() failed: No such file or directory
The following NEW packages will be installed:
  libldap-dev libldap2-dev
The following packages will be upgraded:
  libldap-2.5-0
sh: 0: getcwd() failed: No such file or directory
1 upgraded, 2 newly installed, 0 to remove and 18 not upgraded.
sh: 0: getcwd() failed: No such file or directory
Need to get 498 kB of archives.
After this operation, 1745 kB of additional disk space will be used.
Get:1 http://ap-osaka-1-ad-1.clouds.ports.ubuntu.com/ubuntu-ports jammy-updates/main arm64 libldap-2.5-0 arm64 2.5.12+dfsg-0ubuntu0.22.04.1 [181 kB]
Get:2 http://ap-osaka-1-ad-1.clouds.ports.ubuntu.com/ubuntu-ports jammy-updates/main arm64 libldap-dev arm64 2.5.12+dfsg-0ubuntu0.22.04.1 [310 kB]
Get:3 http://ap-osaka-1-ad-1.clouds.ports.ubuntu.com/ubuntu-ports jammy-updates/main arm64 libldap2-dev all 2.5.12+dfsg-0ubuntu0.22.04.1 [7118 B]
sh: 0: getcwd() failed: No such file or directory
Fetched 498 kB in 2s (202 kB/s)

Preparing to unpack .../libldap-2.5-0_2.5.12+dfsg-0ubuntu0.22.04.1_arm64.deb ...
Unpacking libldap-2.5-0:arm64 (2.5.12+dfsg-0ubuntu0.22.04.1) over (2.5.11+dfsg-1~exp1ubuntu3.1) ...
Selecting previously unselected package libldap-dev:arm64.
Preparing to unpack .../libldap-dev_2.5.12+dfsg-0ubuntu0.22.04.1_arm64.deb ...
Unpacking libldap-dev:arm64 (2.5.12+dfsg-0ubuntu0.22.04.1) ...
Selecting previously unselected package libldap2-dev.
Preparing to unpack .../libldap2-dev_2.5.12+dfsg-0ubuntu0.22.04.1_all.deb ...
Unpacking libldap2-dev (2.5.12+dfsg-0ubuntu0.22.04.1) ...
Setting up libldap-2.5-0:arm64 (2.5.12+dfsg-0ubuntu0.22.04.1) ...
Setting up libldap-dev:arm64 (2.5.12+dfsg-0ubuntu0.22.04.1) ...
Setting up libldap2-dev (2.5.12+dfsg-0ubuntu0.22.04.1) ...
Processing triggers for man-db (2.10.2-1) ...
Processing triggers for libc-bin (2.35-0ubuntu3) ...
NEEDRESTART-VER: 3.5
NEEDRESTART-KCUR: 5.15.0-1011-oracle
NEEDRESTART-KEXP: 5.15.0-1011-oracle
NEEDRESTART-KSTA: 1
NEEDRESTART-SVC: packagekit.service
sh: 0: getcwd() failed: No such file or directory
Reading package lists...
Building dependency tree...
Reading state information...
sh: 0: getcwd() failed: No such file or directory
The following NEW packages will be installed:
  libsodium-dev
sh: 0: getcwd() failed: No such file or directory
0 upgraded, 1 newly installed, 0 to remove and 18 not upgraded.
sh: 0: getcwd() failed: No such file or directory
美国VPS推荐: 遨游主机LinodeLOCVPS主机云VPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2022-6-28 15:18:30 | 显示全部楼层


附近为完整日志!!谢谢军官!!
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
发表于 2022-6-28 19:23:20 | 显示全部楼层

需要按反馈必读要求上传完整日志
美国VPS推荐: 遨游主机LinodeLOCVPS主机云VPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2022-6-29 09:14:57 | 显示全部楼层



http://om.huran.date/lnmp-install.log
完整日期,帮我看下,谢谢。
论坛附件上传有问题,老是上传失败。
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
发表于 2022-6-29 12:27:03 | 显示全部楼层

bomnm 发表于 2022-6-29 09:14
http://om.huran.date/lnmp-install.log
完整日期,帮我看下,谢谢。
论坛附件上传有问题,老是上传失败。 ...

apt install gnutls-dev -y 安装成功后再重新安装

附件无法上传只能按反馈必读要求上传指定渠道

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

 楼主| 发表于 2022-7-1 08:44:15 | 显示全部楼层

谢谢军哥,问题解决。
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2022-8-9 03:36 , Processed in 0.018910 second(s), 16 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表