VPS侦探论坛

 找回密码
 注册
查看: 181|回复: 2

Ubuntu 22.04 lnmp1.9 mysql5.6.51安装失败

[复制链接]
发表于 2022-7-5 15:49:00 | 显示全部楼层 |阅读模式

安装mysql 5.6.51
php 7.1.33


============================== Check install ==============================
Checking ...
Nginx: OK
Error: MySQL install failed.
PHP: OK
PHP-FPM: OK
Sorry, Failed to install LNMP!
Please visit https://bbs.vpser.net/forum-25-1.html feedback errors and logs.
You can download /root/lnmp-install.log from your server,and upload lnmp-install.log to LNMP Forum.

完整日志:https://cowtransfer.com/s/24a8e649edde41 口令:2dd79i 提取;

麻烦看下  谢谢!


美国VPS推荐: 遨游主机LinodeLOCVPS主机云VPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2022-7-5 18:51:04 | 显示全部楼层


OpenSSL 3.0.2 15 Mar 2022 (Library: OpenSSL 3.0.2 15 Mar 2022)
。。。。。。
Cannot find appropriate system libraries for WITH_SSL=system.
Make sure you have specified a supported SSL version.
Valid options are :
system (use the OS openssl library),
yes (synonym for system),
</path/to/custom/openssl/installation>

CMake Error at cmake/ssl.cmake:66 (MESSAGE):
  Please install the appropriate openssl developer package.

Call Stack (most recent call first):
  cmake/ssl.cmake:260 (FATAL_SSL_NOT_FOUND_ERROR)
  CMakeLists.txt:483 (MYSQL_CHECK_SSL)


-- Configuring incomplete, errors occurred!

ubuntu 22.04 的openssl版本为3.0,目前很多程序都是不支持的,编译安装的话mysql的话至少8.0起,即使目前的mysql 8.0原生也是无法支持openssl 3.0的,而是另外加的patch才支持的
x86或x86_64的架构可以选择mysql 5.7或8.0的Generic Binaries(二进制包)安装。
这就是说了安装教程上的“不要在非常新的Linux发行版上安装旧的PHP/MySQL版本,同理不要在旧的Linux发行版上安装非常新的PHP/MySQL版本。”
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2022-7-6 17:12:01 | 显示全部楼层

明白了,谢谢
美国VPS推荐: 遨游主机LinodeLOCVPS主机云VPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2022-8-9 04:14 , Processed in 0.017617 second(s), 16 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表