VPS侦探论坛

 找回密码
 注册
查看: 138|回复: 3

军哥,HELP,高版本ubuntu下memcache安装问题。

[复制链接]
发表于 2022-7-11 22:27:15 | 显示全部楼层 |阅读模式

环境: Ubuntu20.04
lnmp版本:1.8
PHP版本:5.2.17



解除PHP版本限制后,php安装成功,运行正常。
然后安装php-memcache,最终提示安装成功,但是程序运行失败,页面报502错误,原因是执行addServer失败了,找不到这个方法,怀疑是编译memcache.so出现问题,但是日志没报错。
同样的安装方法在centos7.9上没问题,在Ubuntu20上挂了。

已经在QQ联系你了军哥,你没回复俺,山东老乡表示很伤心。



美国VPS推荐: 遨游主机LinodeLOCVPS主机云VPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2022-7-11 22:37:36 | 显示全部楼层


同样环境,测试安装php-memcached日志报错,查询后发现php5.2可能与libmemcache还不兼容,遂放弃。继续测试php-memcache。


在更换不同版本memcached后,发现memcached服务怎么装都能成功,服务能正常运行。出问题的还是php-memcache,但是当前pecl能支持php5.*的最高版本只能是3.0.8,安装低版本2开头的版本都下载不下来,报404错误了。
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2022-7-11 22:39:10 | 显示全部楼层

北京时间:22点39分。

决定降低ubuntu版本试一下,先用ubuntu18试一下,太累了,都怪客户机器太烦人。
美国VPS推荐: 遨游主机LinodeLOCVPS主机云VPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2022-7-12 11:19:13 | 显示全部楼层



php 5.2这种古老版本还是要选择尽量低的系统版本

你在centos 7.9上测试正常 那就是兼容性问题了
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2022-8-11 10:07 , Processed in 0.016595 second(s), 16 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表