VPS侦探论坛

 找回密码
 注册
查看: 162|回复: 4

银河麒麟lnmp1.9,mysql-5.6、php-7.3安装失败

[复制链接]
发表于 2022-7-19 17:09:40 | 显示全部楼层 |阅读模式

本帖最后由 mongoose 于 2022-7-19 17:15 编辑

系统版本:

  1. [root@localhost local]# more /etc/os-release
  2. NAME="Kylin Linux Advanced Server"
  3. VERSION="V10 (Sword)"
  4. ID="kylin"
  5. VERSION_ID="V10"
  6. PRETTY_NAME="Kylin Linux Advanced Server V10 (Sword)"
  7. ANSI_COLOR="0;31"

  8. [root@localhost local]# more /etc/lsb-release
  9. DISTRIB_ID=Kylin
  10. DISTRIB_RELEASE=V10
  11. DISTRIB_CODENAME=juniper
  12. DISTRIB_DESCRIPTION="Kylin V10"
  13. DISTRIB_KYLIN_RELEASE=V10
  14. DISTRIB_VERSION_TYPE=enterprise
  15. DISTRIB_VERSION_MODE=normal
  16. [root@localhost local]# uname -r
  17. 4.19.90-24.4.v2101.ky10.x86_64
复制代码

日志文件:

链接: https://pan.baidu.com/s/1bB5nrisExW_UqgmdgSkbhg 提取码: hwvq 复制这段内容后打开百度网盘手机App,操作更方便哦
--来自百度网盘超级会员v4的分享
美国VPS推荐: 遨游主机LinodeLOCVPS主机云VPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2022-7-20 09:59:55 | 显示全部楼层


[+] Yum installing dependent packages...
CentOS-7 - Base - mirrors.aliyun.com            333 kB/s |  10 MB     00:31   
CentOS-7 - Updates - mirrors.aliyun.com         375 kB/s |  20 MB     00:54   
CentOS-7 - Extras - mirrors.aliyun.com          220 kB/s | 331 kB     00:01   
Last metadata expiration check: 0:00:01 ago on Tue 19 Jul 2022 04:45:33 PM CST.
Package make-1:4.3-1.ky10.x86_64 is already installed.
。。。。。

Error:
Problem: package gcc-c++-4.8.5-44.el7.x86_64 requires gcc = 4.8.5-44.el7, but none of the providers can be installed
  - package kylin-rpm-config-30-13.p02.ky10.x86_64 conflicts with gcc < 7 provided by gcc-4.8.5-44.el7.x86_64
  - conflicting requests
  - problem with installed package kylin-rpm-config-30-13.p02.ky10.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Last metadata expiration check: 0:00:48 ago on Tue 19 Jul 2022 04:45:33 PM CST.
Error:
Problem: package libevent-2.0.21-4.el7.x86_64 requires libcrypto.so.10()(64bit), but none of the providers can be installed
  - package libevent-2.0.21-4.el7.x86_64 requires libcrypto.so.10(libcrypto.so.10)(64bit), but none of the providers can be installed
  - package libevent-2.0.21-4.el7.x86_64 requires libssl.so.10()(64bit), but none of the providers can be installed
  - package libevent-2.0.21-4.el7.x86_64 requires libssl.so.10(libssl.so.10)(64bit), but none of the providers can be installed
  - cannot install both openssl-libs-1:1.0.2k-19.el7.x86_64 and openssl-libs-1:1.1.1f-4.p01.ky10.x86_64
  - cannot install both openssl-libs-1:1.0.2k-21.el7_9.x86_64 and openssl-libs-1:1.1.1f-4.p01.ky10.x86_64
  - cannot install both openssl-libs-1:1.0.2k-22.el7_9.x86_64 and openssl-libs-1:1.1.1f-4.p01.ky10.x86_64
  - cannot install both openssl-libs-1:1.0.2k-24.el7_9.x86_64 and openssl-libs-1:1.1.1f-4.p01.ky10.x86_64
  - cannot install both openssl-libs-1:1.0.2k-25.el7_9.x86_64 and openssl-libs-1:1.1.1f-4.p01.ky10.x86_64
  - package libevent-devel-2.0.21-4.el7.x86_64 requires libevent-2.0.so.5()(64bit), but none of the providers can be installed
  - package libevent-devel-2.0.21-4.el7.x86_64 requires libevent_pthreads-2.0.so.5()(64bit), but none of the providers can be installed
  - package libevent-devel-2.0.21-4.el7.x86_64 requires libevent_core-2.0.so.5()(64bit), but none of the providers can be installed
  - package libevent-devel-2.0.21-4.el7.x86_64 requires libevent_extra-2.0.so.5()(64bit), but none of the providers can be installed
  - package libevent-devel-2.0.21-4.el7.x86_64 requires libevent_openssl-2.0.so.5()(64bit), but none of the providers can be installed
  - package drpm-0.5.0-1.ky10.x86_64 requires libcrypto.so.1.1()(64bit), but none of the providers can be installed
  - package drpm-0.5.0-1.ky10.x86_64 requires libcrypto.so.1.1(OPENSSL_1_1_0)(64bit), but none of the providers can be installed
  - cannot install the best candidate for the job
  - problem with installed package drpm-0.5.0-1.ky10.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

你这居然在Kylin Linux Advanced Server里面设置centos7的源,别指望能安装成功,系统没挂就不错了
虽然说是Kylin Linux Advanced Server基于centos7,但不等于就是也不是仅仅就改个名字而已,也不是任何东西拿来就能用
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2022-7-20 10:16:35 | 显示全部楼层

licess 发表于 2022-7-20 09:59
你这居然在Kylin Linux Advanced Server里面设置centos7的源,别指望能安装成功,系统没挂就不错了
虽然说 ...

佬,这个问题是我的锅。我因为麒麟本身的源比较慢所以替换了,我用它自身的源再重新安装一遍试试。
美国VPS推荐: 遨游主机LinodeLOCVPS主机云VPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2022-7-20 12:17:15 | 显示全部楼层



注意:大家不要替换麒麟的原有的yum源。lnmp1.9版本的脚本,针对mysql-5.6 php-7.3 安装没有问题,非常丝滑。就是慢一些而已。
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2022-7-21 15:48:00 | 显示全部楼层

还是在这里更帖吧。
    我在此版本的麒麟系统上安装了它本身源自带的docker,版本是18.09。拉取了centos:latest 的镜像,并启动了一个容器,然后我在该容器里测试部署安装lnmp。结果是lnmp部署很顺利。

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2022-8-11 11:14 , Processed in 0.017766 second(s), 16 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表