VPS侦探论坛

 找回密码
 注册
查看: 114|回复: 2

离线安装失败1.9

[复制链接]
发表于 2022-7-19 17:57:51 | 显示全部楼层 |阅读模式

Error: PHP install failed.
Sorry, Failed to install LNMP!


1.9离线安装


本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有账号?注册

x
美国VPS推荐: 遨游主机LinodeLOCVPS主机云VPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2022-7-20 10:02:03 | 显示全部楼层


Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Resolving Dependencies
--> Running transaction check
---> Package gd-devel.x86_64 0:2.0.35-26.el7 will be installed
--> Processing Dependency: libXpm-devel for package: gd-devel-2.0.35-26.el7.x86_64
--> Processing Dependency: libX11-devel for package: gd-devel-2.0.35-26.el7.x86_64
--> Processing Dependency: freetype-devel for package: gd-devel-2.0.35-26.el7.x86_64
--> Processing Dependency: fontconfig-devel for package: gd-devel-2.0.35-26.el7.x86_64
--> Running transaction check
---> Package fontconfig-devel.x86_64 0:2.13.0-4.3.el7 will be installed
--> Processing Dependency: pkgconfig(uuid) for package: fontconfig-devel-2.13.0-4.3.el7.x86_64
---> Package freetype-devel.x86_64 0:2.8-14.el7 will be installed
--> Processing Dependency: freetype = 2.8-14.el7 for package: freetype-devel-2.8-14.el7.x86_64
---> Package libX11-devel.x86_64 0:1.6.7-2.el7 will be installed
--> Processing Dependency: libX11 = 1.6.7-2.el7 for package: libX11-devel-1.6.7-2.el7.x86_64
--> Processing Dependency: pkgconfig(xcb) >= 1.11.1 for package: libX11-devel-1.6.7-2.el7.x86_64
--> Processing Dependency: pkgconfig(xproto) for package: libX11-devel-1.6.7-2.el7.x86_64
--> Processing Dependency: pkgconfig(xcb) for package: libX11-devel-1.6.7-2.el7.x86_64
--> Processing Dependency: pkgconfig(kbproto) for package: libX11-devel-1.6.7-2.el7.x86_64
---> Package libXpm-devel.x86_64 0:3.5.12-1.el7 will be installed
--> Running transaction check
---> Package freetype.i686 0:2.8-14.el7 will be installed
--> Processing Dependency: libz.so.1 for package: freetype-2.8-14.el7.i686
--> Processing Dependency: libpng15.so.15(PNG15_0) for package: freetype-2.8-14.el7.i686
--> Processing Dependency: libpng15.so.15 for package: freetype-2.8-14.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.11) for package: freetype-2.8-14.el7.i686
--> Processing Dependency: libbz2.so.1 for package: freetype-2.8-14.el7.i686
---> Package libX11.i686 0:1.6.7-2.el7 will be installed
--> Processing Dependency: libxcb.so.1 for package: libX11-1.6.7-2.el7.i686
---> Package libuuid-devel.x86_64 0:2.23.2-65.el7 will be installed
--> Processing Dependency: libuuid = 2.23.2-65.el7 for package: libuuid-devel-2.23.2-65.el7.x86_64
---> Package libxcb-devel.x86_64 0:1.13-1.el7 will be installed
--> Processing Dependency: pkgconfig(xau) >= 0.99.2 for package: libxcb-devel-1.13-1.el7.x86_64
---> Package xorg-x11-proto-devel.noarch 0:2018.4-1.el7 will be installed
--> Running transaction check
---> Package bzip2-libs.i686 0:1.0.6-13.el7 will be installed
---> Package glibc.i686 0:2.17-317.el7 will be installed
--> Processing Dependency: glibc-common = 2.17-317.el7 for package: glibc-2.17-317.el7.i686
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.17-317.el7.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.17-317.el7.i686
---> Package libXau-devel.x86_64 0:1.0.8-2.1.el7 will be installed
---> Package libpng.i686 2:1.5.13-8.el7 will be installed
---> Package libuuid.i686 0:2.23.2-65.el7 will be installed
---> Package libxcb.i686 0:1.13-1.el7 will be installed
--> Processing Dependency: libXau.so.6 for package: libxcb-1.13-1.el7.i686
---> Package zlib.i686 0:1.2.7-18.el7 will be installed
--> Running transaction check
---> Package glibc.i686 0:2.17-317.el7 will be installed
--> Processing Dependency: glibc-common = 2.17-317.el7 for package: glibc-2.17-317.el7.i686
---> Package libXau.i686 0:1.0.8-2.1.el7 will be installed
---> Package nss-softokn-freebl.i686 0:3.44.0-8.el7_7 will be installed
--> Finished Dependency Resolution
Error: Package: glibc-2.17-317.el7.i686 (local-media)
           Requires: glibc-common = 2.17-317.el7
           Installed: glibc-common-2.17-325.el7_9.x86_64 (@updates)
               glibc-common = 2.17-325.el7_9
           Available: glibc-common-2.17-317.el7.x86_64 (local-media)
               glibc-common = 2.17-317.el7
You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
authconfig-6.2.8-30.el7.x86_64 has missing requires of /usr/bin/openssl
。。。。。。

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Resolving Dependencies
--> Running transaction check
---> Package libxslt-devel.x86_64 0:1.1.28-6.el7 will be installed
--> Processing Dependency: pkgconfig(libxml-2.0) for package: libxslt-devel-1.1.28-6.el7.x86_64
--> Processing Dependency: libgcrypt-devel for package: libxslt-devel-1.1.28-6.el7.x86_64
--> Running transaction check
---> Package libgcrypt-devel.x86_64 0:1.5.3-14.el7 will be installed
--> Processing Dependency: libgpg-error-devel for package: libgcrypt-devel-1.5.3-14.el7.x86_64
---> Package libxml2-devel.x86_64 0:2.9.1-6.el7.5 will be installed
--> Processing Dependency: libxml2 = 2.9.1-6.el7.5 for package: libxml2-devel-2.9.1-6.el7.5.x86_64
--> Processing Dependency: xz-devel for package: libxml2-devel-2.9.1-6.el7.5.x86_64
--> Running transaction check
---> Package libgpg-error-devel.x86_64 0:1.12-3.el7 will be installed
---> Package libxml2.i686 0:2.9.1-6.el7.5 will be installed
--> Processing Dependency: libz.so.1(ZLIB_1.2.3.3) for package: libxml2-2.9.1-6.el7.5.i686
--> Processing Dependency: libz.so.1(ZLIB_1.2.2.3) for package: libxml2-2.9.1-6.el7.5.i686
--> Processing Dependency: libz.so.1 for package: libxml2-2.9.1-6.el7.5.i686
--> Processing Dependency: libm.so.6(GLIBC_2.1) for package: libxml2-2.9.1-6.el7.5.i686
--> Processing Dependency: libm.so.6(GLIBC_2.0) for package: libxml2-2.9.1-6.el7.5.i686
--> Processing Dependency: libm.so.6 for package: libxml2-2.9.1-6.el7.5.i686
--> Processing Dependency: liblzma.so.5(XZ_5.0) for package: libxml2-2.9.1-6.el7.5.i686
--> Processing Dependency: liblzma.so.5 for package: libxml2-2.9.1-6.el7.5.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.1) for package: libxml2-2.9.1-6.el7.5.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.0) for package: libxml2-2.9.1-6.el7.5.i686
--> Processing Dependency: libdl.so.2 for package: libxml2-2.9.1-6.el7.5.i686
--> Processing Dependency: libc.so.6(GLIBC_2.15) for package: libxml2-2.9.1-6.el7.5.i686
---> Package xz-devel.x86_64 0:5.2.2-1.el7 will be installed
--> Running transaction check
---> Package glibc.i686 0:2.17-317.el7 will be installed
--> Processing Dependency: glibc-common = 2.17-317.el7 for package: glibc-2.17-317.el7.i686
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.17-317.el7.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.17-317.el7.i686
---> Package xz-libs.i686 0:5.2.2-1.el7 will be installed
---> Package zlib.i686 0:1.2.7-18.el7 will be installed
--> Running transaction check
---> Package glibc.i686 0:2.17-317.el7 will be installed
--> Processing Dependency: glibc-common = 2.17-317.el7 for package: glibc-2.17-317.el7.i686
---> Package nss-softokn-freebl.i686 0:3.44.0-8.el7_7 will be installed
--> Finished Dependency Resolution
Error: Package: glibc-2.17-317.el7.i686 (local-media)
           Requires: glibc-common = 2.17-317.el7
           Installed: glibc-common-2.17-325.el7_9.x86_64 (@updates)
               glibc-common = 2.17-325.el7_9
           Available: glibc-common-2.17-317.el7.x86_64 (local-media)
               glibc-common = 2.17-317.el7
You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
authconfig-6.2.8-30.el7.x86_64 has missing requires of /usr/bin/openssl

你这个像是在联网情况下使用yum安装过软件包后又离线安装导致的
yum distro-sync 同步一下,与本地源一致之后应该就可以了
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2022-7-20 13:28:20 | 显示全部楼层

谢谢。
离线安装。yum是无效的。
问题出现在rpm的包和yum自带的包相冲突.
解决了 。
问题出现在libxml2上面。gcclib的版本不一致造成的。
美国VPS推荐: 遨游主机LinodeLOCVPS主机云VPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2022-8-11 11:39 , Processed in 0.018487 second(s), 17 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表