VPS侦探论坛

 找回密码
 注册
查看: 159|回复: 6

安装lamp失败-lnmp1.9-full

[复制链接]
发表于 2022-7-20 16:06:54 | 显示全部楼层 |阅读模式

checking whether to enable LIBXML support... yes
checking libxml2 install dir... /usr
checking for xml2-config path...
configure: error: xml2-config not found. Please check your libxml2 installation.
make: *** No targets specified and no makefile found.  Stop.
make: *** No targets specified and no makefile found.  Stop.
make: *** No rule to make target `install'.  Stop.
Copy new php configure file...
Modify php.ini......
include/php.sh: line 190: pear: command not found
include/php.sh: line 191: pecl: command not found

Install ZendGuardLoader for PHP 5.6...
zend-loader-php5.6-linux-x86_64.tar.gz [found]
Uncompress zend-loader-php5.6-linux-x86_64.tar.gz...
Write ZendGuardLoader to php.ini...
Clean PHP src directory...
Create PHP Info Tool...
Copy PHP Prober...
Copy Opcache Control Panel...
============================Install PHPMyAdmin=================================
============================phpMyAdmin install completed=======================
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
Package iptables-services-1.4.21-35.el7.x86_64 already installed and latest version
Nothing to do
iptables: Saving firewall rules to /etc/sysconfig/iptables: [  OK  ]
Redirecting to /bin/systemctl reload iptables.service
Job for iptables.service invalid.
Add iptables service at system startup...
Add Startup and Starting LAMP...
Add httpd service at system startup...
Created symlink from /etc/systemd/system/multi-user.target.wants/httpd.service to /etc/systemd/system/httpd.service.
Job for httpd.service failed because the control process exited with error code. See "systemctl status httpd.service" and "journalctl -xe" for details.
Add mysql service at system startup...
Error: Apache install failed.
MySQL: OK
Error: PHP install failed.
Sorry, Failed to install LNMP!
Please visit https://bbs.vpser.net/forum-25-1.html feedback errors and logs.
You can download /root/lnmp-install.log from your server,and upload lnmp-install.log to LNMP Forum.
[root@wc-wds-209 lnmp1.9-full]#

美国VPS推荐: 遨游主机LinodeLOCVPS主机云VPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2022-7-20 21:09:43 | 显示全部楼层


Resolving Dependencies
--> Running transaction check
---> Package gd-devel.x86_64 0:2.0.35-26.el7 will be installed
--> Processing Dependency: gd = 2.0.35-26.el7 for package: gd-devel-2.0.35-26.el7.x86_64
--> Processing Dependency: freetype-devel for package: gd-devel-2.0.35-26.el7.x86_64
--> Processing Dependency: fontconfig-devel for package: gd-devel-2.0.35-26.el7.x86_64
--> Running transaction check
---> Package fontconfig-devel.x86_64 0:2.13.0-4.3.el7 will be installed
--> Processing Dependency: pkgconfig(uuid) for package: fontconfig-devel-2.13.0-4.3.el7.x86_64
---> Package freetype-devel.x86_64 0:2.8-14.el7 will be installed
--> Processing Dependency: freetype = 2.8-14.el7 for package: freetype-devel-2.8-14.el7.x86_64
---> Package gd.i686 0:2.0.35-26.el7 will be installed
--> Processing Dependency: libz.so.1 for package: gd-2.0.35-26.el7.i686
--> Processing Dependency: libpng15.so.15(PNG15_0) for package: gd-2.0.35-26.el7.i686
--> Processing Dependency: libpng15.so.15 for package: gd-2.0.35-26.el7.i686
--> Processing Dependency: libm.so.6(GLIBC_2.1) for package: gd-2.0.35-26.el7.i686
--> Processing Dependency: libm.so.6(GLIBC_2.0) for package: gd-2.0.35-26.el7.i686
--> Processing Dependency: libm.so.6 for package: gd-2.0.35-26.el7.i686
--> Processing Dependency: libjpeg.so.62(LIBJPEG_6.2) for package: gd-2.0.35-26.el7.i686
--> Processing Dependency: libjpeg.so.62 for package: gd-2.0.35-26.el7.i686
--> Processing Dependency: libfontconfig.so.1 for package: gd-2.0.35-26.el7.i686
--> Processing Dependency: libc.so.6(GLIBC_2.11) for package: gd-2.0.35-26.el7.i686
--> Processing Dependency: libXpm.so.4 for package: gd-2.0.35-26.el7.i686
--> Processing Dependency: libX11.so.6 for package: gd-2.0.35-26.el7.i686
--> Running transaction check
---> Package fontconfig.i686 0:2.13.0-4.3.el7 will be installed
--> Processing Dependency: libuuid.so.1(UUID_1.0) for package: fontconfig-2.13.0-4.3.el7.i686
--> Processing Dependency: libuuid.so.1 for package: fontconfig-2.13.0-4.3.el7.i686
--> Processing Dependency: libexpat.so.1 for package: fontconfig-2.13.0-4.3.el7.i686
---> Package freetype.i686 0:2.8-14.el7 will be installed
--> Processing Dependency: libbz2.so.1 for package: freetype-2.8-14.el7.i686
---> Package glibc.i686 0:2.17-317.el7 will be installed
--> Processing Dependency: glibc-common = 2.17-317.el7 for package: glibc-2.17-317.el7.i686
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.17-317.el7.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.17-317.el7.i686
---> Package libX11.i686 0:1.6.7-2.el7 will be installed
--> Processing Dependency: libxcb.so.1 for package: libX11-1.6.7-2.el7.i686
---> Package libXpm.i686 0:3.5.12-1.el7 will be installed
---> Package libjpeg-turbo.i686 0:1.2.90-8.el7 will be installed
---> Package libpng.i686 2:1.5.13-8.el7 will be installed
---> Package libuuid-devel.x86_64 0:2.23.2-65.el7 will be installed
---> Package zlib.i686 0:1.2.7-18.el7 will be installed
--> Running transaction check
---> Package bzip2-libs.i686 0:1.0.6-13.el7 will be installed
---> Package expat.i686 0:2.1.0-12.el7 will be installed
---> Package glibc.i686 0:2.17-317.el7 will be installed
--> Processing Dependency: glibc-common = 2.17-317.el7 for package: glibc-2.17-317.el7.i686
---> Package libuuid.i686 0:2.23.2-65.el7 will be installed
---> Package libxcb.i686 0:1.13-1.el7 will be installed
--> Processing Dependency: libXau.so.6 for package: libxcb-1.13-1.el7.i686
---> Package nss-softokn-freebl.i686 0:3.44.0-8.el7_7 will be installed
--> Running transaction check
---> Package glibc.i686 0:2.17-317.el7 will be installed
--> Processing Dependency: glibc-common = 2.17-317.el7 for package: glibc-2.17-317.el7.i686
---> Package libXau.i686 0:1.0.8-2.1.el7 will be installed
--> Finished Dependency Resolution
Error: Package: glibc-2.17-317.el7.i686 (local)
           Requires: glibc-common = 2.17-317.el7
           Installed: glibc-common-2.17-325.el7_9.x86_64 (@updates)
               glibc-common = 2.17-325.el7_9
           Available: glibc-common-2.17-317.el7.x86_64 (local)
               glibc-common = 2.17-317.el7
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
Package matching libxml2-2.9.1-6.el7.5.x86_64 already installed. Checking for update.
Nothing to do
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
Resolving Dependencies
--> Running transaction check
---> Package libxml2-devel.x86_64 0:2.9.1-6.el7.5 will be installed
--> Processing Dependency: libxml2 = 2.9.1-6.el7.5 for package: libxml2-devel-2.9.1-6.el7.5.x86_64
--> Processing Dependency: xz-devel for package: libxml2-devel-2.9.1-6.el7.5.x86_64
--> Running transaction check
---> Package libxml2.i686 0:2.9.1-6.el7.5 will be installed
--> Processing Dependency: libz.so.1(ZLIB_1.2.3.3) for package: libxml2-2.9.1-6.el7.5.i686
--> Processing Dependency: libz.so.1(ZLIB_1.2.2.3) for package: libxml2-2.9.1-6.el7.5.i686
--> Processing Dependency: libz.so.1 for package: libxml2-2.9.1-6.el7.5.i686
--> Processing Dependency: libm.so.6(GLIBC_2.1) for package: libxml2-2.9.1-6.el7.5.i686
--> Processing Dependency: libm.so.6(GLIBC_2.0) for package: libxml2-2.9.1-6.el7.5.i686
--> Processing Dependency: libm.so.6 for package: libxml2-2.9.1-6.el7.5.i686
--> Processing Dependency: liblzma.so.5(XZ_5.0) for package: libxml2-2.9.1-6.el7.5.i686
--> Processing Dependency: liblzma.so.5 for package: libxml2-2.9.1-6.el7.5.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.1) for package: libxml2-2.9.1-6.el7.5.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.0) for package: libxml2-2.9.1-6.el7.5.i686
--> Processing Dependency: libdl.so.2 for package: libxml2-2.9.1-6.el7.5.i686
--> Processing Dependency: libc.so.6(GLIBC_2.15) for package: libxml2-2.9.1-6.el7.5.i686
---> Package xz-devel.x86_64 0:5.2.2-1.el7 will be installed
--> Running transaction check
---> Package glibc.i686 0:2.17-317.el7 will be installed
--> Processing Dependency: glibc-common = 2.17-317.el7 for package: glibc-2.17-317.el7.i686
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.17-317.el7.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.17-317.el7.i686
---> Package xz-libs.i686 0:5.2.2-1.el7 will be installed
---> Package zlib.i686 0:1.2.7-18.el7 will be installed
--> Running transaction check
---> Package glibc.i686 0:2.17-317.el7 will be installed
--> Processing Dependency: glibc-common = 2.17-317.el7 for package: glibc-2.17-317.el7.i686
---> Package nss-softokn-freebl.i686 0:3.44.0-8.el7_7 will be installed
--> Finished Dependency Resolution
Error: Package: glibc-2.17-317.el7.i686 (local)
           Requires: glibc-common = 2.17-317.el7
           Installed: glibc-common-2.17-325.el7_9.x86_64 (@updates)
               glibc-common = 2.17-325.el7_9
           Available: glibc-common-2.17-317.el7.x86_64 (local)
               glibc-common = 2.17-317.el7
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

你这个像是在联网情况下使用yum安装过软件包且进行的离线安装而且与本地源软件包版本不一致导致的
执行命令:yum distro-sync
同步一下,与本地源版本一致之后再安装lnmp应该就可以了
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2022-7-20 16:41:21 | 显示全部楼层

换成lnmp1.8-full也不行

Install ZendGuardLoader for PHP 5.6...
Notice:  not found!!!download now...
--2022-07-20 16:39:22--  https://soft.vpser.net/web/zend/ ... linux-x86_64.tar.gz
Resolving soft.vpser.net (soft.vpser.net)... failed: Name or service not known.
wget: unable to resolve host address ‘soft.vpser.net’
Write ZendGuardLoader to php.ini...
Clean PHP src directory...
Create PHP Info Tool...
Copy PHP Prober...
Copy Opcache Control Panel...
============================Install PHPMyAdmin=================================
============================phpMyAdmin install completed=======================
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
Package iptables-services-1.4.21-35.el7.x86_64 already installed and latest version
Nothing to do
iptables: Saving firewall rules to /etc/sysconfig/iptables: [  OK  ]
Redirecting to /bin/systemctl reload iptables.service
Job for iptables.service invalid.
Add iptables service at system startup...
Add Startup and Starting LAMP...
Add httpd service at system startup...
Created symlink from /etc/systemd/system/multi-user.target.wants/httpd.service to /etc/systemd/system/httpd.service.
Job for httpd.service failed because the control process exited with error code. See "systemctl status httpd.service" and "journalctl -xe" for details.
Add mysql service at system startup...
Error: Apache install failed.
MySQL: OK
Error: PHP install failed.
Sorry, Failed to install LNMP!
Please visit https://bbs.vpser.net/forum-25-1.html feedback errors and logs.
You can download /root/lnmp-install.log from your server,and upload lnmp-install.log to LNMP Forum.
美国VPS推荐: 遨游主机LinodeLOCVPS主机云VPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2022-7-20 17:17:07 | 显示全部楼层



贴出的日志中没有有用信息,需要按反馈必读要求提供完整日志信息
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2022-7-20 17:43:49 | 显示全部楼层

licess 发表于 2022-7-20 17:17
贴出的日志中没有有用信息,需要按反馈必读要求提供完整日志信息

https://www.wenshushu.cn/f/8ueeorxgsa5

安装日志,麻烦看下!!!多谢

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

 楼主| 发表于 2022-7-20 17:46:22 | 显示全部楼层

min1423813868 发表于 2022-7-20 17:43
https://www.wenshushu.cn/f/8ueeorxgsa5

安装日志,麻烦看下!!!多谢

CentOS Linux release 7.6.1810 (Core)
 楼主| 发表于 2022-7-21 09:31:26 | 显示全部楼层

licess 发表于 2022-7-20 21:09
你这个像是在联网情况下使用yum安装过软件包且进行的离线安装而且与本地源软件包版本不一致导致的
执行命 ...

感谢大佬!!!可以了
美国VPS推荐: 遨游主机LinodeLOCVPS主机云VPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2022-8-17 21:12 , Processed in 0.036704 second(s), 21 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表