VPS侦探论坛

 找回密码
 注册
查看: 80|回复: 5

lnmp1.9升级mysql5.7失败

[复制链接]
发表于 2022-7-31 11:46:42 | 显示全部楼层 |阅读模式

军哥看看呢


https://t.wss.ink/f/8xgwp9971sb 复制链接到浏览器打开
美国VPS推荐: 遨游主机LinodeLOCVPS主机云VPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2022-7-31 14:14:20 | 显示全部楼层


Cannot find appropriate system libraries for WITH_SSL=system.
Make sure you have specified a supported SSL version.
Valid options are :
system (use the OS openssl library),
yes (synonym for system),
</path/to/custom/openssl/installation>

CMake Error at cmake/ssl.cmake:66 (MESSAGE):
  Please install the appropriate openssl developer package.

Call Stack (most recent call first):
  cmake/ssl.cmake:260 (FATAL_SSL_NOT_FOUND_ERROR)
  CMakeLists.txt:483 (MYSQL_CHECK_SSL)


-- Configuring incomplete, errors occurred!

你系统上缺少 openssl-devel 依赖包或者可能自行升级过openssl且有问题导致mysql无法找到openssl
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2022-7-31 16:28:36 | 显示全部楼层

军哥,我是通过一键包安装的lnmp环境,nginx的openssl也正常的
美国VPS推荐: 遨游主机LinodeLOCVPS主机云VPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2022-7-31 20:53:20 | 显示全部楼层



io565 发表于 2022-7-31 16:28
军哥,我是通过一键包安装的lnmp环境,nginx的openssl也正常的

nginx本来就不使用系统自带的openssl
rhel系的rpm -qa|grep openssl-devel
debian系的dpkg -L|grep openssl-dev
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 6 天前 | 显示全部楼层

军哥,我记得openssl一键包都是好像初始化会自动安装的,我以前也没有遇到过openssl的问题。
是因为一键包和centos stream 9有兼容问题吗

补充内容 (2022-8-2 13:30):
Package openssl-devel-1:3.0.1-38.el9.x86_64 is already installed.
我yum openssl-devel是正常的

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

发表于 6 天前 | 显示全部楼层

io565 发表于 2022-8-2 13:19
军哥,我记得openssl一键包都是好像初始化会自动安装的,我以前也没有遇到过openssl的问题。
是因为一键包 ...

只有在一些低版本php、高版本openssl的情况下才会另外单独编译openssl供php使用

mysql升级日志只有mysql编译相关信息没有系统相关信息其他无法确定

centos steam 9的话只要别选太低版本的话一般都是可用安装的
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2022-8-8 00:10 , Processed in 0.029261 second(s), 16 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表