VPS侦探论坛

 找回密码
 注册
查看: 86|回复: 3

阿里云Ubuntu22.04安装LNMP1.9失败

[复制链接]
发表于 7 天前 | 显示全部楼层 |阅读模式

本帖最后由 西南小白 于 2022-8-1 00:42 编辑

军哥,我使用最新的LNMP1.9安装失败了,具体情况如下:


服务器:阿里云
系统:Ubuntu22.04
配置:1核,2G内存,40G硬盘
安装流程:首先,我完全重置了服务器,选择系统版本为Ubuntu22.04;之后,我使用了apt-get update和apt-get upgrade对原始系统进行基本的升级;然后,开启一个screen进程,直接用wget方式安装LNMP1.9,并选择MariaDB为10.6.8版本,PHP选择为7.4.28,安装失败了。

(在此之前,我还安装过一次,其中PHP为8.1.6,也失败了,才想着完全重置后选个低版本的,没想到也失败了。)

安装过程最终显示的信息为:
Checking ...

Nginx: OK
MariaDB: OK
Error: PHP install failed.
Sorry, Failed to install LNMP!
Please visit https://bbs.vpser.net/forum-25-1.html feedback errors and logs.
You can download /root/lnmp-install.log from your server,and upload lnmp-install.log to LNMP Forum.


更具体的安装LOG,见文叔叔:wenshushu.cn
提取地址:https://t.wss.ink/f/8xmdd0mtnez  (有效期24小时)

感谢军哥解惑!
美国VPS推荐: 遨游主机LinodeLOCVPS主机云VPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 7 天前 | 显示全部楼层


本帖最后由 西南小白 于 2022-8-1 00:41 编辑

军哥,第一次用那个文叔叔,不知道你那边能不能正常打开,不行就叫我
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
发表于 7 天前 | 显示全部楼层

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libicu-dev : Depends: libicu70 (= 70.1-2) but 70.1-2ubuntu1 is to be installed
E: Unable to correct problems, you have held broken packages.
Reading package lists...
Building dependency tree...
Reading state information...
e2fsprogs is already the newest version (1.46.5-2ubuntu1.1).
e2fsprogs set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
libxslt1.1 is already the newest version (1.1.34-4build2).
libxslt1.1 set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libicu-dev : Depends: libicu70 (= 70.1-2) but 70.1-2ubuntu1 is to be installed
E: Unable to correct problems, you have held broken packages.
。。。。。。
checking whether to build with LIBXML support... yes
checking for libxml-2.0 >= 2.7.6... no
configure: error: Package requirements (libxml-2.0 >= 2.7.6) were not met:

No package 'libxml-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBXML_CFLAGS
and LIBXML_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

你这个 libicu70 软件包依赖关系有问题导致依赖包 libxml2-dev 、 libicu-dev等几个依赖包没有安装成功

可用尝试 apt-get install libicu70=70.1-2ubuntu1
也可以 apt-get remove libicu70 后再 apt-get install libicu-dev
如果都不行可以尝试 apt-get install aptitude 后 aptitude install libicu-dev 按提示输入 n 不接受后再输入 y 确认降级

最后尝试  apt-get install libxml2-dev 看一下能否正常安装,正常安装了再重新安装lnmp
美国VPS推荐: 遨游主机LinodeLOCVPS主机云VPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 7 天前 | 显示全部楼层



licess 发表于 2022-8-1 09:23
你这个 libicu70 软件包依赖关系有问题导致依赖包 libxml2-dev 、 libicu-dev等几个依赖包没有安装成功

...

感谢军哥,我晚上回去试试
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2022-8-8 00:42 , Processed in 0.017909 second(s), 16 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表