VPS侦探论坛

 找回密码
 注册
查看: 415|回复: 6

无网络安装lnmp1.9 到php的时候报错

[复制链接]
发表于 2022-8-25 00:18:22 | 显示全部楼层 |阅读模式


Error: PHP install failed.
Sorry, Failed to install LNMP!
Please visit https://bbs.vpser.net/forum-25-1.html feedback errors and logs.
You can download /root/lnmp-install.log from your server,and upload lnmp-install.log to LNMP Forum.

美国VPS推荐: 遨游主机LinodeLOCVPS主机云VPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2022-8-25 00:20:58 | 显示全部楼层


错误文件:http://114.132.233.42/lnmp-install.log
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2022-8-25 00:21:12 | 显示全部楼层

麻烦大佬帮忙看下
美国VPS推荐: 遨游主机LinodeLOCVPS主机云VPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2022-8-25 09:56:17 | 显示全部楼层



已加载插件:fastestmirror, langpacks
Loading mirror speeds from cached hostfile
正在解决依赖关系
--> 正在检查事务
---> 软件包 gd-devel.x86_64.0.2.0.35-26.el7 将被 安装
--> 正在处理依赖关系 gd = 2.0.35-26.el7,它被软件包 gd-devel-2.0.35-26.el7.x86_64 需要
--> 正在处理依赖关系 freetype-devel,它被软件包 gd-devel-2.0.35-26.el7.x86_64 需要
--> 正在处理依赖关系 fontconfig-devel,它被软件包 gd-devel-2.0.35-26.el7.x86_64 需要
--> 正在检查事务
---> 软件包 fontconfig-devel.x86_64.0.2.13.0-4.3.el7 将被 安装
--> 正在处理依赖关系 pkgconfig(uuid),它被软件包 fontconfig-devel-2.13.0-4.3.el7.x86_64 需要
---> 软件包 freetype-devel.x86_64.0.2.8-14.el7 将被 安装
--> 正在处理依赖关系 freetype = 2.8-14.el7,它被软件包 freetype-devel-2.8-14.el7.x86_64 需要
---> 软件包 gd.i686.0.2.0.35-26.el7 将被 安装
--> 正在处理依赖关系 libz.so.1,它被软件包 gd-2.0.35-26.el7.i686 需要
--> 正在处理依赖关系 libpng15.so.15(PNG15_0),它被软件包 gd-2.0.35-26.el7.i686 需要
--> 正在处理依赖关系 libpng15.so.15,它被软件包 gd-2.0.35-26.el7.i686 需要
--> 正在处理依赖关系 libm.so.6(GLIBC_2.1),它被软件包 gd-2.0.35-26.el7.i686 需要
--> 正在处理依赖关系 libm.so.6(GLIBC_2.0),它被软件包 gd-2.0.35-26.el7.i686 需要
--> 正在处理依赖关系 libm.so.6,它被软件包 gd-2.0.35-26.el7.i686 需要
--> 正在处理依赖关系 libjpeg.so.62(LIBJPEG_6.2),它被软件包 gd-2.0.35-26.el7.i686 需要
--> 正在处理依赖关系 libjpeg.so.62,它被软件包 gd-2.0.35-26.el7.i686 需要
--> 正在处理依赖关系 libfontconfig.so.1,它被软件包 gd-2.0.35-26.el7.i686 需要
--> 正在处理依赖关系 libc.so.6(GLIBC_2.11),它被软件包 gd-2.0.35-26.el7.i686 需要
--> 正在处理依赖关系 libXpm.so.4,它被软件包 gd-2.0.35-26.el7.i686 需要
--> 正在处理依赖关系 libX11.so.6,它被软件包 gd-2.0.35-26.el7.i686 需要
--> 正在检查事务
---> 软件包 fontconfig.i686.0.2.13.0-4.3.el7 将被 安装
--> 正在处理依赖关系 libuuid.so.1(UUID_1.0),它被软件包 fontconfig-2.13.0-4.3.el7.i686 需要
--> 正在处理依赖关系 libuuid.so.1,它被软件包 fontconfig-2.13.0-4.3.el7.i686 需要
--> 正在处理依赖关系 libexpat.so.1,它被软件包 fontconfig-2.13.0-4.3.el7.i686 需要
---> 软件包 freetype.i686.0.2.8-14.el7 将被 安装
--> 正在处理依赖关系 libbz2.so.1,它被软件包 freetype-2.8-14.el7.i686 需要
---> 软件包 glibc.i686.0.2.17-317.el7 将被 安装
--> 正在处理依赖关系 glibc-common = 2.17-317.el7,它被软件包 glibc-2.17-317.el7.i686 需要
--> 正在处理依赖关系 libfreebl3.so(NSSRAWHASH_3.12.3),它被软件包 glibc-2.17-317.el7.i686 需要
--> 正在处理依赖关系 libfreebl3.so,它被软件包 glibc-2.17-317.el7.i686 需要
---> 软件包 libX11.i686.0.1.6.7-2.el7 将被 安装
--> 正在处理依赖关系 libxcb.so.1,它被软件包 libX11-1.6.7-2.el7.i686 需要
---> 软件包 libXpm.i686.0.3.5.12-1.el7 将被 安装
---> 软件包 libjpeg-turbo.i686.0.1.2.90-8.el7 将被 安装
---> 软件包 libpng.i686.2.1.5.13-8.el7 将被 安装
---> 软件包 libuuid-devel.x86_64.0.2.23.2-65.el7 将被 安装
---> 软件包 zlib.i686.0.1.2.7-18.el7 将被 安装
--> 正在检查事务
---> 软件包 bzip2-libs.i686.0.1.0.6-13.el7 将被 安装
---> 软件包 expat.i686.0.2.1.0-12.el7 将被 安装
---> 软件包 glibc.i686.0.2.17-317.el7 将被 安装
--> 正在处理依赖关系 glibc-common = 2.17-317.el7,它被软件包 glibc-2.17-317.el7.i686 需要
---> 软件包 libuuid.i686.0.2.23.2-65.el7 将被 安装
---> 软件包 libxcb.i686.0.1.13-1.el7 将被 安装
--> 正在处理依赖关系 libXau.so.6,它被软件包 libxcb-1.13-1.el7.i686 需要
---> 软件包 nss-softokn-freebl.i686.0.3.44.0-8.el7_7 将被 安装
--> 正在检查事务
---> 软件包 glibc.i686.0.2.17-317.el7 将被 安装
--> 正在处理依赖关系 glibc-common = 2.17-317.el7,它被软件包 glibc-2.17-317.el7.i686 需要
---> 软件包 libXau.i686.0.1.0.8-2.1.el7 将被 安装
--> 解决依赖关系完成
错误:软件包:glibc-2.17-317.el7.i686 (local-media)
          需要:glibc-common = 2.17-317.el7
          已安装: glibc-common-2.17-326.el7_9.x86_64 (@base)
              glibc-common = 2.17-326.el7_9
          可用: glibc-common-2.17-317.el7.x86_64 (local-media)
              glibc-common = 2.17-317.el7
您可以尝试添加 --skip-broken 选项来解决该问题

已加载插件:fastestmirror, langpacks
Loading mirror speeds from cached hostfile
正在解决依赖关系
--> 正在检查事务
---> 软件包 libwebp-devel.x86_64.0.0.3.0-7.el7 将被 安装
--> 正在处理依赖关系 libwebp(x86-64) = 0.3.0-7.el7,它被软件包 libwebp-devel-0.3.0-7.el7.x86_64 需要
--> 解决依赖关系完成
错误:软件包:libwebp-devel-0.3.0-7.el7.x86_64 (local-media)
          需要:libwebp(x86-64) = 0.3.0-7.el7
          已安装: libwebp-0.3.0-10.el7_9.x86_64 (@base)
              libwebp(x86-64) = 0.3.0-10.el7_9
          可用: libwebp-0.3.0-7.el7.x86_64 (local-media)
              libwebp(x86-64) = 0.3.0-7.el7
您可以尝试添加 --skip-broken 选项来解决该问题
** 发现 3 个已存在的 RPM 数据库问题, 'yum check' 输出如下:
redhat-lsb-core-4.1-27.el7.centos.1.x86_64 有缺少的需求 /usr/sbin/sendmail
redhat-lsb-core-4.1-27.el7.centos.1.x86_64 有缺少的需求 redhat-lsb-submod-security(x86-64) = ('0', '4.1', '27.el7.centos.1')
redhat-lsb-core-4.1-27.el7.centos.1.x86_64 有缺少的需求 spax

/home/lnmp1.9-full/src/php-7.1.33/ext/phar/util.c:1563: undefined reference to `EVP_MD_CTX_new'
/home/lnmp1.9-full/src/php-7.1.33/ext/phar/util.c:1595: undefined reference to `EVP_MD_CTX_free'
/home/lnmp1.9-full/src/php-7.1.33/ext/phar/util.c:1586: undefined reference to `EVP_MD_CTX_free'
ext/phar/.libs/util.o: In function `phar_create_signature':
/home/lnmp1.9-full/src/php-7.1.33/ext/phar/util.c:1860: undefined reference to `EVP_MD_CTX_new'
/home/lnmp1.9-full/src/php-7.1.33/ext/phar/util.c:1892: undefined reference to `EVP_MD_CTX_free'
ext/xmlrpc/libxmlrpc/.libs/encodings.o: In function `convert':
/home/lnmp1.9-full/src/php-7.1.33/ext/xmlrpc/libxmlrpc/encodings.c:74: undefined reference to `libiconv_open'
/home/lnmp1.9-full/src/php-7.1.33/ext/xmlrpc/libxmlrpc/encodings.c:82: undefined reference to `libiconv'
/home/lnmp1.9-full/src/php-7.1.33/ext/xmlrpc/libxmlrpc/encodings.c:102: undefined reference to `libiconv_close'
/home/lnmp1.9-full/src/php-7.1.33/ext/xmlrpc/libxmlrpc/encodings.c:102: undefined reference to `libiconv_close'

首先你系统依赖关系存在问题,可以参考:https://bbs.vpser.net/thread-26066-1-1.html 解决
其次你系统升级过openssl且是有问题的导致php会报错
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2022-8-25 15:43:31 | 显示全部楼层

licess 发表于 2022-8-25 09:56
首先你系统依赖关系存在问题,可以参考:https://bbs.vpser.net/thread-26066-1-1.html 解决
其次你系统升 ...

哥,openssl这个需要怎么解决,卸载了  安装旧版本嘛

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

发表于 2022-8-25 19:42:51 | 显示全部楼层

邓dcx 发表于 2022-8-25 15:43
哥,openssl这个需要怎么解决,卸载了  安装旧版本嘛

把自己安装的openssl卸载,再 yum reinstall openssl openssl-devel
 楼主| 发表于 2022-8-25 20:03:54 | 显示全部楼层

licess 发表于 2022-8-25 19:42
把自己安装的openssl卸载,再 yum reinstall openssl openssl-devel

好的 谢谢哥
美国VPS推荐: 遨游主机LinodeLOCVPS主机云VPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2022-10-5 09:37 , Processed in 0.021011 second(s), 16 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表