VPS侦探论坛

 找回密码
 注册
查看: 294|回复: 1

手动升级了openssl,现在无法一键安装lnmp了!

[复制链接]
发表于 2022-9-1 13:46:37 | 显示全部楼层 |阅读模式

手动升级了openssl,安装目录在/usrl/local/openssl


现在无法一键安装lnmp,有没有办法修改配置文件,让PHP调用这个路径的openssl呢?

这个是安装日志:http://45.207.47.251/install.log

管理员能够帮忙看下吗?
美国VPS推荐: 遨游主机LinodeLOCVPS主机云VPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2022-9-1 19:31:59 | 显示全部楼层


-lm -ldl -lcrypt -lxml2 -lz -lm -ldl -lxml2 -lz -lm -ldl -lxml2 -lz -lm -ldl -lxml2 -lz -lm -ldl -lxslt -lxml2 -lz -ldl -lm -lssl -lcrypto -lcrypt -liconv -o sapi/cli/php
/usr/bin/ld: warning: libcrypto.so.1.1, needed by /usr/lib64/libssl.so, may conflict with libcrypto.so.10
/usr/bin/ld: warning: libcrypto.so.1.1, needed by /usr/lib64/libssl.so, may conflict with libcrypto.so.10
/usr/bin/ld: warning: libcrypto.so.1.1, needed by /usr/lib64/libssl.so, may conflict with libcrypto.so.10
/usr/bin/ld: warning: libssl.so.10, needed by //usr/lib64/libssh2.so.1, may conflict with libssl.so.1.1
/usr/bin/ld: warning: libssl.so.10, needed by //usr/lib64/libssh2.so.1, may conflict with libssl.so.1.1
/usr/bin/ld: warning: libssl.so.10, needed by //usr/lib64/libssh2.so.1, may conflict with libssl.so.1.1
/usr/bin/ld: ext/openssl/.libs/xp_ssl.o: undefined reference to symbol 'SSLv3_server_method@@libssl.so.10'
//usr/lib64/libssl.so.10: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status

说过很多次了的问题,不要自行升级openssl,除非你能保证升级不会有问题
你在帖子上加了openssl标签已经给你关联上相关同问题的帖子
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2022-10-5 10:43 , Processed in 0.016491 second(s), 20 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表