VPS侦探论坛

 找回密码
 注册
查看: 507|回复: 4

求助:lnmp1.9安装php失败

[复制链接]
发表于 2022-10-14 16:42:09 | 显示全部楼层 |阅读模式

lnmp1.9安装php失败 nginx和mysql都安装成功了 就php安装不成功
附上附件  
链接:https://pan.baidu.com/s/1vuOQPw91a43A5NqVmaakzg
提取码:6666
美国VPS推荐: 遨游主机LinodeLOCVPS主机云VPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2022-10-15 12:03:12 | 显示全部楼层


checking whether to build with LIBXML support... yes
checking for libxml-2.0 >= 2.9.0... no
configure: error: Package requirements (libxml-2.0 >= 2.9.0) were not met:

No package 'libxml-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBXML_CFLAGS
and LIBXML_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

你这日志中半点libxml依赖包安装的信息都没有,要不就是修改了安装脚本或者可能你系统或系统源设置有问题

你可以执行 apt-get install libxml2-dev
apt-get search libxml2-dev
看看有什么返回信息
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2022-10-15 13:16:33 | 显示全部楼层

licess 发表于 2022-10-15 12:03
你这日志中半点libxml依赖包安装的信息都没有,要不就是修改了安装脚本或者可能你系统或系统源设置有问题
...

root@aliyun001:/# apt-get install libxml2-dev
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libicu-dev : Depends: libicu70 (= 70.1-2) but 70.1-2ubuntu1 is to be installed
E: Unable to correct problems, you have held broken packages.


显示这个,是不是源的问题,腾讯云上装的好好地,阿里云上就是装不上
美国VPS推荐: 遨游主机LinodeLOCVPS主机云VPS2EZ搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2022-10-16 09:28:16 | 显示全部楼层



nonename 发表于 2022-10-15 13:16
root@aliyun001:/# apt-get install libxml2-dev
Reading package lists... Done
Building dependency tr ...

这个有可能是你系统之前添加了proposed预发布软件源安装了libicu后来又去掉了proposed源导致的依赖问题,可以参考:https://bbs.vpser.net/thread-26280-1-1.html
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2022-10-16 10:46:27 | 显示全部楼层

licess 发表于 2022-10-16 09:28
这个有可能是你系统之前添加了proposed预发布软件源安装了libicu后来又去掉了proposed源导致的依赖问题, ...

好的 多谢 军哥 麻烦军哥了

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2022-12-6 22:13 , Processed in 0.045808 second(s), 16 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表