VPS侦探论坛

 找回密码
 注册
查看: 223|回复: 4

Error: PHP install failed.

[复制链接]
发表于 2022-12-7 22:10:26 | 显示全部楼层 |阅读模式


武汉云
CentOS Linux release 7.9.2009 (Core)
lnmp1.9
安装失败

安装日志
美国VPS推荐: 遨游主机LinodeLOCVPS主机云搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2022-12-8 09:26:23 | 显示全部楼层


没有日志没法判断可能原因,按反馈必读要求提供安装日志
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2022-12-11 09:22:09 | 显示全部楼层

licess 发表于 2022-12-8 09:26
没有日志没法判断可能原因,按反馈必读要求提供安装日志
安装日志:
https://t.wss.ink/f/9zenb39p98k
美国VPS推荐: 遨游主机LinodeLOCVPS主机云搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2022-12-11 16:38:06 | 显示全部楼层



猫布偶k 发表于 2022-12-11 09:22
安装日志:
https://t.wss.ink/f/9zenb39p98k
Loaded plugins: fastestmirror, langpacks
Repository base is listed more than once in the configuration
Repository updates is listed more than once in the configuration
Repository extras is listed more than once in the configuration
Repository centosplus is listed more than once in the configuration
Loading mirror speeds from cached hostfile
* extras: mirrors.njupt.edu.cn
* updates: mirrors.njupt.edu.cn
Resolving Dependencies
--> Running transaction check
---> Package gd-devel.x86_64 0:2.0.35-27.el7_9 will be installed
--> Processing Dependency: libpng-devel for package: gd-devel-2.0.35-27.el7_9.x86_64
--> Processing Dependency: libjpeg-devel for package: gd-devel-2.0.35-27.el7_9.x86_64
--> Processing Dependency: libXpm-devel for package: gd-devel-2.0.35-27.el7_9.x86_64
--> Processing Dependency: freetype-devel for package: gd-devel-2.0.35-27.el7_9.x86_64
--> Processing Dependency: fontconfig-devel for package: gd-devel-2.0.35-27.el7_9.x86_64
--> Running transaction check
---> Package freetype-devel.x86_64 0:2.8-14.el7_9.1 will be installed
--> Processing Dependency: pkgconfig(libpng) for package: freetype-devel-2.8-14.el7_9.1.x86_64
---> Package gd-devel.x86_64 0:2.0.35-27.el7_9 will be installed
--> Processing Dependency: libpng-devel for package: gd-devel-2.0.35-27.el7_9.x86_64
--> Processing Dependency: libjpeg-devel for package: gd-devel-2.0.35-27.el7_9.x86_64
--> Processing Dependency: libXpm-devel for package: gd-devel-2.0.35-27.el7_9.x86_64
--> Processing Dependency: fontconfig-devel for package: gd-devel-2.0.35-27.el7_9.x86_64
--> Finished Dependency Resolution
Error: Package: gd-devel-2.0.35-27.el7_9.x86_64 (updates)
           Requires: fontconfig-devel
Error: Package: gd-devel-2.0.35-27.el7_9.x86_64 (updates)
           Requires: libXpm-devel
Error: Package: gd-devel-2.0.35-27.el7_9.x86_64 (updates)
           Requires: libjpeg-devel
Error: Package: freetype-devel-2.8-14.el7_9.1.x86_64 (updates)
           Requires: pkgconfig(libpng)
Error: Package: gd-devel-2.0.35-27.el7_9.x86_64 (updates)
           Requires: libpng-devel
You could try using --skip-broken to work around the problem
** Found 3 pre-existing rpmdb problem(s), 'yum check' output follows:
gnome-keyring-3.28.2-1.el7.x86_64 has missing requires of /usr/bin/ssh-add
gnome-keyring-3.28.2-1.el7.x86_64 has missing requires of /usr/bin/ssh-agent
python-meh-0.25.3-1.el7.noarch has missing requires of openssh-clients

。。。。。
Repository base is listed more than once in the configuration
Repository updates is listed more than once in the configuration
Repository extras is listed more than once in the configuration
Repository centosplus is listed more than once in the configuration
Loading mirror speeds from cached hostfile
* extras: mirrors.njupt.edu.cn
* updates: mirrors.njupt.edu.cn
No package sqlite-devel available.

首先系统源设置有问题,某些包都找不到,重新设置系统源
2依赖关系有问题,可以参考:https://bbs.vpser.net/thread-26066-1-1.html
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2022-12-11 20:25:32 | 显示全部楼层

licess 发表于 2022-12-11 16:38
首先系统源设置有问题,某些包都找不到,重新设置系统源
2依赖关系有问题,可以参考:https://bbs.vpser ...

改为阿里源后重装正常

美国VPS、VPN、域名代购:http://shop63846532.taobao.com/

您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2023-2-2 16:25 , Processed in 0.046060 second(s), 16 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表