VPS侦探论坛

 找回密码
 注册
查看: 226|回复: 3

centos7离线安装lnmp1.8失败

[复制链接]
发表于 2022-12-16 18:23:37 | 显示全部楼层 |阅读模式

nginx安装成功,php和mysql安装失败,文档链接:https://t.wss.ink/f/a0xvp4a2q9v 复制链接到浏览器打开
美国VPS推荐: 遨游主机LinodeLOCVPS主机云搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2022-12-17 09:21:51 | 显示全部楼层


Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Resolving Dependencies
--> Running transaction check
---> Package openssl-devel.x86_64 1:1.0.1e-42.el7.9 will be installed
--> Processing Dependency: openssl-libs(x86-64) = 1:1.0.1e-42.el7.9 for package: 1:openssl-devel-1.0.1e-42.el7.9.x86_64
--> Finished Dependency Resolution
Error: Package: 1:openssl-devel-1.0.1e-42.el7.9.x86_64 (local-media)
           Requires: openssl-libs(x86-64) = 1:1.0.1e-42.el7.9
           Installed: 1:openssl-libs-1.0.1e-51.el7_2.2.x86_64 (@updates)
               openssl-libs(x86-64) = 1:1.0.1e-51.el7_2.2
           Available: 1:openssl-libs-1.0.1e-42.el7.9.x86_64 (local-media)
               openssl-libs(x86-64) = 1:1.0.1e-42.el7.9
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

。。。。。。
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Resolving Dependencies
--> Running transaction check
---> Package gmp-devel.x86_64 1:6.0.0-11.el7 will be installed
--> Processing Dependency: gmp = 1:6.0.0-11.el7 for package: 1:gmp-devel-6.0.0-11.el7.x86_64
--> Finished Dependency Resolution
Error: Package: 1:gmp-devel-6.0.0-11.el7.x86_64 (local-media)
           Requires: gmp = 1:6.0.0-11.el7
           Installed: 1:gmp-6.0.0-12.el7_1.x86_64 (@updates)
               gmp = 1:6.0.0-12.el7_1
           Available: 1:gmp-6.0.0-11.el7.x86_64 (local-media)
               gmp = 1:6.0.0-11.el7
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

。。。。。。

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Resolving Dependencies
--> Running transaction check
---> Package libxslt-devel.x86_64 0:1.1.28-5.el7 will be installed
--> Processing Dependency: pkgconfig(libxml-2.0) for package: libxslt-devel-1.1.28-5.el7.x86_64
--> Processing Dependency: libgcrypt-devel for package: libxslt-devel-1.1.28-5.el7.x86_64
--> Running transaction check
---> Package libgcrypt-devel.x86_64 0:1.5.3-12.el7_1.1 will be installed
--> Processing Dependency: libgpg-error-devel for package: libgcrypt-devel-1.5.3-12.el7_1.1.x86_64
---> Package libxml2-devel.x86_64 0:2.9.1-5.el7_1.2 will be installed
--> Processing Dependency: libxml2 = 2.9.1-5.el7_1.2 for package: libxml2-devel-2.9.1-5.el7_1.2.x86_64
--> Processing Dependency: xz-devel for package: libxml2-devel-2.9.1-5.el7_1.2.x86_64
--> Running transaction check
---> Package libgpg-error-devel.x86_64 0:1.12-3.el7 will be installed
---> Package libxml2-devel.x86_64 0:2.9.1-5.el7_1.2 will be installed
--> Processing Dependency: libxml2 = 2.9.1-5.el7_1.2 for package: libxml2-devel-2.9.1-5.el7_1.2.x86_64
---> Package xz-devel.x86_64 0:5.1.2-12alpha.el7 will be installed
--> Finished Dependency Resolution
Error: Package: libxml2-devel-2.9.1-5.el7_1.2.x86_64 (local-media)
           Requires: libxml2 = 2.9.1-5.el7_1.2
           Installed: libxml2-2.9.1-6.el7_2.2.x86_64 (@updates)
               libxml2 = 2.9.1-6.el7_2.2
           Available: libxml2-2.9.1-5.el7_1.2.x86_64 (local-media)
               libxml2 = 2.9.1-5.el7_1.2
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

你这之前用过网络源安装过软件包,用的本地源和之前的网络源版本不一致肯定会各种报错
可以参考:https://bbs.vpser.net/thread-26066-1-1.html
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2022-12-19 11:33:09 | 显示全部楼层

本帖最后由 czl747 于 2022-12-19 11:39 编辑
licess 发表于 2022-12-17 09:21
你这之前用过网络源安装过软件包,用的本地源和之前的网络源版本不一致肯定会各种报错
可以参考:https:// ...

麻烦大佬在看下,PHP成功了,MySql安装失败

文档链接:
https://t.wss.ink/f/a1pu6xy9f9f 复制链接到浏览器打开
美国VPS推荐: 遨游主机LinodeLOCVPS主机云搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2022-12-19 18:57:30 | 显示全部楼层



czl747 发表于 2022-12-19 11:33
麻烦大佬在看下,PHP成功了,MySql安装失败

文档链接:
-- Performing Test HAVE_POINTER_SIGN
-- Performing Test HAVE_POINTER_SIGN - Success
CMake Error at extra/libedit/libedit-20191231-3.1/src/CMakeLists.txt:150 (TARGET_COMPILE_OPTIONS):
  Unknown CMake command "TARGET_COMPILE_OPTIONS".


-- Configuring incomplete, errors occurred!

自己修改过mysql的编译参数吗?
没修过的话,不清楚什么问题,可以尝试使用lnmp1.9选择二进制的mysql版本
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2023-1-28 02:42 , Processed in 0.048189 second(s), 16 queries .

Powered by Discuz! X3.4

Copyright © 2001-2021, Tencent Cloud.

快速回复 返回顶部 返回列表