打印

lnmp 0.7装完在Discuz X1.5后台显示不支持eAccelerator

lnmp 0.7装完在Discuz X1.5后台显示不支持eAccelerator

军哥麻烦看一下,我在VPS上装了lnmp0.7,去Discuz X1.5后台作内存优化的时候发现显示PHP不支持eAccelerator,但是我之前用lnmp0.6安装的是没问题的。

我用你的探针程序和phpinfo看过都显示是支持eAccelerator的,麻烦看看问题出在哪里,谢了。




正确的是这样的:
附件: 您所在的用户组无法下载或查看附件

TOP

Lz你搞错了……这个不支持不是指环境不支持而是你没在设置里打开让DZ支持……
恩 具体哪里改忘记了
反正是DX的一个设置文件里………………改好后 就显示 支持了。。。。。。。

TOP

可能是eaccelerator版本的问题吧,编辑eaccelerator.sh文件,将里面的
复制内容到剪贴板
代码:
wget -c http://bart.eaccelerator.net/source/0.9.6.1/eaccelerator-0.9.6.1.tar.bz2
tar jxvf eaccelerator-0.9.6.1.tar.bz2
cd eaccelerator-0.9.6.1/
替换为:
复制内容到剪贴板
代码:
wget -c http://soft.vpser.net/web/eaccelerator/eaccelerator-0.9.5.3.tar.bz2
tar jxvf eaccelerator-0.9.5.3.tar.bz2
cd eaccelerator-0.9.5.3/
再重启apache试试

TOP

谢谢军哥,改了版本重新执行安装脚本,已经好了。
那你是不是在下一版要把eaccelerator.sh改一下呀?
引用:
原帖由 licess 于 2011-5-1 21:39 发表
可能是eaccelerator版本的问题吧,编辑eaccelerator.sh文件,将里面的
wget -c http://bart.eaccelerator.net/source/0.9.6.1/eaccelerator-0.9.6.1.tar.bz2
tar jxvf eaccelerator-0.9.6.1.tar.bz2
cd eaccelerator-0.9 ...

TOP

这个是 eaccelerator  的问题 , 从 discuz 官方得到的消息称 eaccelerator 从0.9.5.3 之后不支持神马缓存 。。

也就是 必须装 0.9.5.3  版本的 eaccelerator

TOP

引用:
原帖由 红星 于 2011-5-3 10:13 发表
这个是 eaccelerator  的问题 , 从 discuz 官方得到的消息称 eaccelerator 从0.9.5.3 之后不支持神马缓存 。。

也就是 必须装 0.9.5.3  版本的 eaccelerator
哦,了解,谢谢,顺便问一下,还有memcache和Xcache这两种和eaccelerator比起来效能哪个好一点。

TOP

memcache  适合超大数据量 的站 做分布式 缓存用 。

eaccelerator   适合访问速度要求较高的站,但是不需要做分布式负载均衡的站使用   。

Xcache  听说对Discuz 支持不太好 ,就没有用过

[ 本帖最后由 红星 于 2011-11-19 21:04 编辑 ]

TOP

我修改了 但是重新安装的时候就提示错误啊

TOP

成功啦 谢谢军哥 啊

TOP

memcache 是否比EA更好??

TOP

回复 10# 的帖子

优先选择  memcache   ,memcache会把数据缓存在它所占用的内存中。形成数据岛,按照你的设置的时间同步到数据库 。但memcache相对而言,占用内存大点 。适合超大数据的站用。

[ 本帖最后由 红星 于 2011-11-19 21:05 编辑 ]

TOP

那已经安装好的了LNMP怎么办?

TOP

eaccelerator.sh  在哪?/root/lnmp0.7-full 找到一个

TOP

安装好了,再运行就是重装。

就是lnmp的解压目录

TOP

回复 14# 的帖子

我是直接安装0.7的,按方法安装了eAccelerator后,过程中没有提示错误,但是用探针查看的时候就是不支持

TOP