Board logo

标题: lnmp1.4-lamp 安装后运行laravel报错 [打印本页]

作者: jasester    时间: 2017-8-4 14:02     标题: lnmp1.4-lamp 安装后运行laravel报错

运行后 报这个错误Warning: require(): open_basedir restriction in effect. File(/home/wwwroot/ is not within the allowed path(s): (/home/wwwroot/ in /home/wwwroot/ on line 22

Warning: require(/home/wwwroot/ failed to open stream: Operation not permitted in /home/wwwroot/ on line 22

Fatal error: require(): Failed opening required '/home/wwwroot/' (include_path='.:/usr/local/php/lib/php') in /home/wwwroot/ on line 22

也在php.ini中修改了open_basedir  也不管用。
作者: licess    时间: 2017-8-4 21:02
作者: evilk    时间: 2017-8-7 13:10

安装laravel 后,要更改 bootstrap/  storage/   的读写权限,还要把 /usr/local/nginx/conf/fastcgi.conf   中 最后一行 fastcgi_param PHP_ADMIN_VALUE "open_basedir=$document_root/:/tmp/:/proc/"   注释掉

欢迎光临 VPS侦探论坛 ( Powered by Discuz! 6.0.0