Board logo

标题: 使用https后安装证书后网站提示这样的错误 [打印本页]

作者: zzuyanan1    时间: 2017-11-8 15:58     标题: 使用https后安装证书后网站提示这样的错误

lnmp是军哥最新版的,自己申请了asiatrust的证书。chrome浏览器,网站打开后提示:
使用了不受支持的协议。
ERR_SSL_VERSION_OR_CIPHER_MISMATCH客户端和服务器不支持常用的 SSL 协议版本或加密套件。导致此问题的原因通常是服务器要求使用 RC4,而这种加密方式根据当前标准已不够安全。


但是firefox正常。
作者: licess    时间: 2017-11-8 19:11

lnmp默认的https站点配置中没有rc4的cipher,配置文件改过吗
你系统什么版本,chrome什么版本
作者: zzuyanan1    时间: 2017-11-10 09:49     标题: 回复 2# 的帖子

没有改过任何配置文件,我是xp系统,chrome是48。但是如果仍然xp系统,换成firefox就正常。是不是xp系统不支持啊。还是证书有问题。
但是我看别的https的网站跟我一样的证书,同样xp和chrome48环境下就正常。
作者: zzuyanan1    时间: 2017-11-10 09:51     标题: 回复 3# 的帖子

会不会跟openssl有关,1.0.1e的版本
作者: licess    时间: 2017-11-10 17:58

xp本来就只支持到SSLv2 和SSLv3,这两个协议还有漏洞,还不支持sni而且还不支持sha256签名算法,对https支持肯定也就不行,要想支持到xp就只能冒险开sslv3,但是你ip上多个https站点的话还是会有问题,以为xp不支持sni
firefox本来就是个特例,他使用自己的不使用系统自带的
作者: zzuyanan1    时间: 2017-11-11 11:13     标题: 回复 5# 的帖子

但是同样的xp和chrome环境访问https://lnmp.org/就是可以正常访问,而且还能探测到http/2开启状态,这是为啥呢?
作者: licess    时间: 2017-11-11 19:26

不清楚
lnmp.org 网站上https的配置,除了证书和伪静态其他都是lnmp工具自带生成的配置是一样的
作者: zzuyanan1    时间: 2017-11-12 13:56     标题: 回复 7# 的帖子

做付费问题排查吗?
作者: licess    时间: 2017-11-12 18:59     标题: 回复 8# 的帖子

签名中有联系方式




欢迎光临 VPS侦探论坛 (http://bbs.vpser.net/) Powered by Discuz! 6.0.0