Board logo

标题: lnmp1.4升级php7.2无法升级会报错哇 [打印本页]

作者: ifre    时间: 2017-12-3 09:07     标题: lnmp1.4升级php7.2无法升级会报错哇

军哥可以检查下代码, 升级php7.2 会报错
作者: licess    时间: 2017-12-3 11:03

暂时还没测试
你发一下错误信息看看
作者: bb12343    时间: 2017-12-3 18:23

升级才刚开始,就自己结束了[attach]4788[/attach]
作者: bb12343    时间: 2017-12-3 18:24

再次尝试就会出现:[attach]4789[/attach]
作者: prouser    时间: 2017-12-4 01:45

确实,同上,恢复快照尝试了两次。阿里云香港,Debian8 64,原来的php版本是7.1.12和7.1.11(都是一路用lnmp升级上来的)
作者: licess    时间: 2017-12-4 13:06

因为php 7.2未做适配所有是无法直接安装的,可以自己改 include/upgrade_php.sh 将最后最后倒数几行里面的 7.[01]. 改 7.[012]. 试试
作者: ifre    时间: 2017-12-4 18:56

引用:
原帖由 licess 于 2017-12-4 13:06 发表
因为php 7.2未做适配所有是无法直接安装的,可以自己改 include/upgrade_php.sh 将最后最后倒数几行里面的 7.[01]. 改 7.[012]. 试试
照这个改了好像还是不行哇
[attach]4794[/attach]
作者: prouser    时间: 2017-12-4 21:07

引用:
原帖由 licess 于 2017-12-4 13:06 发表
因为php 7.2未做适配所有是无法直接安装的,可以自己改 include/upgrade_php.sh 将最后最后倒数几行里面的 7.[01]. 改 7.[012]. 试试
成功,进入编译了。

[attach]4795[/attach]
引用:
原帖由 ifre 于 2017-12-4 18:56 发表

照这个改了好像还是不行哇
4794
因为旧的脚本升级前删掉了php的一些文件吧,我在正常运行的7.1.11上修改后upgrade是可以的。



编译顺利,花费17分钟左右。

[ 本帖最后由 prouser 于 2017-12-4 21:21 编辑 ]
作者: ifre    时间: 2017-12-5 10:17     标题: 回复 8# 的帖子

具体改什么方法说出来哇.
作者: licess    时间: 2017-12-5 11:34

按上面6楼的方法修改是没问题的,7.2.0 测试安装正常
作者: cyhour    时间: 2017-12-5 11:38     标题: 回复 6# 的帖子

升级成功。
————————————————————
昨晚没改脚本升级,直接挂掉了……
作者: buxuhunao    时间: 2017-12-9 14:12

刚好遇到一样的问题,发现这个帖子  真给力




欢迎光临 VPS侦探论坛 (http://bbs.vpser.net/) Powered by Discuz! 6.0.0