打印

使用的一键安装包,但如何开启IMAP模块呢

回复 15# 的帖子

http://zh.wikipedia.org/zh/IMAP 自己看一下维基吧

TOP

重新走走看!!!重新走走看!!!重新走走看!!!

TOP

参考:

ubuntu下php安装时找不到libjpeg和libpng的解决办法
sudo apt-get install libjpeg8-dev
sudo ln -s /usr/lib/i386-linux-gnu/libpng.so /usr/lib/libpng.so


http://blog.csdn.net/moviethief/archive/2011/06/17/6552013.aspx




安装时应该debian需要执行apt-get install libc-client-dev ,centos执行yum install libc-client-devel
修改脚本时需要在php编译的./configure这一行的后面添加 --with-imap --with-imap-ssl --with-kerberos 再编译安装。

configure: error: Kerberos libraries not found.
      
      Check the path given to --with-kerberos (if no path is given, searches in /usr/kerberos, /usr/local and /usr )

然后

apt-get install libc-client-dev

正在读取软件包列表... 完成
正在分析软件包的依赖关系树      
正在读取状态信息... 完成      
注意,选取 libc-client2007e-dev 而非 libc-client-dev
libc-client2007e-dev 已经是最新的版本了。
升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件包未被升级。

apt-get remove libc-client-*

重新编译。出现了这个错误!

configure: error: utf8_mime2text() has new signature, but U8T_CANONICAL is missing. This should not happen. Check config.log for additional information.


ubuntu11.04版本会出现这个错误!

[ 本帖最后由 liyunlong 于 2011-6-24 11:42 编辑 ]

TOP

原来我以前的贴子有解决过。。。

https://bbs.vpser.net/viewthread.php?tid=3062&page=1#pid8130

TOP

回复 11# 的帖子

用了你的方法奏效

TOP