打印

lnmp1.2版本安装GBK版本的discuz X3.2乱码

没关系,,,也就在你安装的时候会显示乱码,   你自己手动改一下为gbk编码安装就成了,   
安装后就正常显示的.  因为安装php页面没有做强制编码,   安装后论坛配制里是强制GBK编码的..      
这个不影响你论坛的正常运行.

如果实在纠结这个,,,那你就强制把php.ini 里的默认编码改为  bgk就成了

sed -i 's/default_charset = \"UTF-8\"/default_charset = \"gbk\"/g' /usr/local/php/etc/php.ini
/etc/init.d/php-fpm restart

如果你的程序都是GBK程序还好,,要是还有Utf-8程序,,那也会出现乱码,编码不能正常识别.

TOP