打印

京东云 jcloud centos 无法安装LNMP一键安装包暂时解决方法

京东云 jcloud centos 无法安装LNMP一键安装包暂时解决方法

京东云自带openssl非原系统的openssl,应该是jcloud那边自编译上的,openssl版本是1.1.0b,太新太高,造成php等一些软件无法安装。
复制内容到剪贴板
代码:
[root@jdu4e00u53f7 lnmp1.4]# /usr/bin/openssl version
OpenSSL 1.1.0b  26 Sep 2016
[root@jdu4e00u53f7 lnmp1.4]# /usr/bin/openssl.bak version
OpenSSL 1.0.1e-fips 11 Feb 2013
[root@jdu4e00u53f7 lnmp1.4]# ls -l /usr/bin/openssl
lrwxrwxrwx 1 root root 22 Dec 20 14:53 /usr/bin/openssl -> /usr/local/bin/openssl
解决方法如下:
复制内容到剪贴板
代码:
rm -rf /usr/local/bin/openssl /usr/local/include/openssl/ /usr/bin/openssl
mv /usr/bin/openssl.bak /usr/bin/openssl
ldconfig
运行该命令后重启一下,重新安装lnmp就没问题了

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP

已经向jcloud反馈,不知道后续怎样
update:据京东云反馈说是安全部门要求的,目前正在和安全部协商处理中

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP

openssl 1.1.0本来就是个短命的版本,好像明年6、7月付就EOL了
1.0.2才是LTS,用1.0.2替代才是比较好的版本

完全等php新版的话也不太现实,php 5.5-的版本的话就完全没法用的

编译命令可以

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP

回复 9# 的帖子

有ssl,EVP_CIPHER的都是和openssl有关

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP