打印

[已解决]lnmp1.4版树莓派3 arm64 debian9 mysql编译失败

不清楚原因

TOP

回复 4# 的帖子

查了一下好像是raspberry pi3开始才是aarch64的,你那边测试安装可以了不

TOP

回复 7# 的帖子

最简单的方式是改 include/php.sh 将 if [[ "${DISTRO}" = "CentOS" && "${Is_ARM}" = "y" ]];then 改成 if [[ "${DISTRO}" = "CentOS" || "${Is_ARM}" = "y" ]];then
改完保存重新安装就可以了

另外的方法
你可以下是不是有 /usr/include/aarch64-linux-gnu/curl 目录,有的话ln -s 软链接到 /usr/include/ 目录下

TOP

回复 11# 的帖子

configure: error: cannot guess build type; you must specify one
make: *** No targets specified and no makefile found.  Stop.
[+] Installing libmcrypt-2.5.8
Uncompress libmcrypt-2.5.8.tar.gz...
cd libmcrypt-2.5.8...
checking build system type... ./config.guess: unable to guess system type

This script, last modified 2003-06-17, has failed to recognize
the operating system you are using. It is advised that you
download the most up to date version of the config scripts from

    ftp://ftp.gnu.org/pub/gnu/config/

If the version you run (./config.guess) is already up to date, please
send the following data and any information you think might be
pertinent to <config-patches@gnu.org> in order to provide the needed
information to handle your system.

config.guess timestamp = 2003-06-17

uname -m = aarch64
uname -r = 4.11.12-pi64+
uname -s = Linux
uname -v = #1 SMP PREEMPT Sun Jul 30 20:18:20 CEST 2017

/usr/bin/uname -p =
/bin/uname -X     =

hostinfo               =
/bin/universe          =
/usr/bin/arch -k       =
/bin/arch              =
/usr/bin/oslevel       =
/usr/convex/getsysinfo =

UNAME_MACHINE = aarch64
UNAME_RELEASE = 4.11.12-pi64+
UNAME_SYSTEM  = Linux
UNAME_VERSION = #1 SMP PREEMPT Sun Jul 30 20:18:20 CEST 2017
configure: error: cannot guess build type; you must specify one

aarch64架构下mycrypt、libmycrypt都没法编译安装,而且aarch64架构下官网上也没libmcrypt-dev的包,这个依赖包应该有10几年不更新了,不需要mcrypt扩展的话可以修改编译参数去掉,mycrypt扩展从 PHP 7.1.0 开始废弃;自 PHP 7.2.0 起,会移到 PECL。

TOP

回复 13# 的帖子

必须要mcrypt的话我也没办法,除非mcrypt更新并支持才行

TOP