打印

Lmmp1.4和Lnmp1.5 是否安装了PHP ZipArchive?

Lmmp1.4和Lnmp1.5 是否安装了PHP ZipArchive?

军哥,你好:

因为在还原网站时要求PHP ZipArchive必须安装。好像没安装,如何安装它?

谢谢!

[ 本帖最后由 786880322 于 2018-5-18 16:23 编辑 ]

TOP

默认都自带zip模块

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP

谢谢军哥:

我使用插件Duplicator还原网站时,得到了如下提示,看下面的截图。这是怎么回事?
In order to extract the archive.zip file the PHP ZipArchive module must be installed.

是不是Duplicator要求的 PHP Ziparchive 和 Lnmp自带的不是同一个版本的?
谢谢!





[ 本帖最后由 786880322 于 2018-5-19 13:13 编辑 ]
附件: 您所在的用户组无法下载或查看附件

TOP

回复 3# 的帖子

所有版本都带zip,我们测试都是在1.5上测试的没问题,不清楚你具体php版本情况没法进行测试
截图2上说的可能你zip文件有问题

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP

军哥,你好:

PHP我都选的最高版本,Lnmp1.4的PHP应是7.1.7, Lnmp1.5的PHP应是7.2.5

谢谢!

[ 本帖最后由 786880322 于 2018-5-20 06:53 编辑 ]

TOP

回复 5# 的帖子

目前最高版本的5.6.36, 7.1.17,7.2.5测试了没有问题

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP

回复 6# 的帖子

军哥,lnmp1.5 ,php 7.2.5 ,我安装 nextcloud ,提示 PHP zip 模块未安装,怎么解决 ? 谢谢 !
我下载了 zip 安装包,运行  ./configure --with-php-config=/usr/local/php/bin/php-config

提示错误

checking for libzip... configure: error: system libzip must be upgraded to version >= 0.11

yum update libzip 提示没有更新包。

[ 本帖最后由 nic2013 于 2018-5-26 09:44 编辑 ]

TOP

回复 7# 的帖子

centos上目前版本的libzip-devel 都是小于0.11的没法用,只能使用zip不能用libzip
下载最新的lnmp1.5,然后升级一下php版本到7.2.6 再试一下看看

LNMP付费问题排查/LNMP技术支持/Paypal信用卡代付/代购VPS,域名,软件等 QQ 503228080 旺旺 lzhenbao
军哥淘宝店铺
QQ/旺旺仅提供代购及付费代维/问题解决等服务,其他不回复!LNMP相关问题请在本论坛发帖,提问前先搜索,按https://bbs.vpser.net/thread-2555-1-1.html 要求反馈问题!

TOP