打印

趁着lnmp1.6测试提个建议

趁着lnmp1.6测试提个建议

LNMP最常用的环境是Nginx/MySQL/PHP,
目前lnmp1.6测试版默认安装的版本是Nginx1.14、MySQL5.5、PHP5.6
不过PHP5.6和MySQL5.5官方都已经停止了安全更新,已经是不安全的版本了
http://php.net/eol.php  PHP5.6于2018年12月31日停止所有安全更新支持
https://en.wikipedia.org/wiki/MySQL  MySQL5.5也End of support在December 2018
基于此建议lnmp1.6测试版默认使用MySQL5.6或更高版本,
如果非要使用旧版可以使用MariaDB5.5这个版本支持到2020年3月
https://www.fromdual.com/support-for-mysql-from-oracle
PHP建议默认选择PHP7.2
由于PHP7.0和PHP5.6都已经停止支持,PHP7.2使用的人最多应用最广是最好的选择,
LNMP的默认环境作为广大建站爱好者的默认选择,安装的默认版本都是不再支持的危险版本实在不妥,
希望可以从最基本的安全出发从谏如流,早日做出相应的更改。

TOP

引用:
原帖由 蛋蛋的蛋 于 2019-1-6 17:24 发表
原来mjj那个是你 :lolhttps://i.loli.net/2019/01/06/5c31c93e2dcdc.png
我只是收到了启发,才会提这个建议的。
附件: 您所在的用户组无法下载或查看附件

TOP

回复 4# 的帖子

既然已经知道是存在安全风险的默认选择,虽然还没有爆发风险,但也应该做出积极的调整,
即使由于各种原因您不愿接受我的合理建议,您也应该在(default)后面加入提示,让用户意识到风险的存在,以引导用户做出更合理的选择。

TOP

回复 6# 的帖子

您可以在论坛发个投票看看不知道php5.6、php7.0和mysql5.5官方已经停止安全更新的人有没有1%,不知道您是怎么得出使用lnmp一键脚本的人都知道,是从哪里来的数据。我这只是个建议,接不接受也不是我绑架的了的。至于你认为我的建议有什么问题可以提出来,或者您有更好的建议。

TOP

回复 9# 的帖子

没有添加任何东西,只是非常细微的改动,不影响必须使用旧版的用户。
我测试了十来个vps(有256M内存的,有512M内存的有1G内存的有openvz的有xen的有kvm的)安装LNMP(Linux+Nginx+MariaDB5.5+PHP7.2)都没有问题。

TOP

回复 8# 的帖子

的确很多人不是小白,不过他们都比较懒,安装时喜欢直接回车回车回车,这样安装下来就是有风险的生产环境,按照我说的细微调整好,对那些回车党比较负责一些,哈哈哈

TOP

也许吧,改不改我也不说了

TOP

回复 14# 的帖子

您这个思路真让我大开眼界了,那您电脑都用回xp吧,这个够老,肯定不存在安全问题的

TOP

引用:
原帖由 cinbo 于 2019-1-11 14:13 发表
楼猪你这杠精 ,根据自己的程序编码支持,你爱用哪个就哪个,不喜欢可以自己换。
在请问XP和现在新版WIN系统差多少年,你PHP5 和PHP7差多久。现在你去看用最新版的WIN系统用户最多吗? ...
最早的php5.0是2004年推出的,现在官方支持的最旧版本php7.1是2016年推出的,差了12年
xp是2001年推出的,现在官方支持的win7是2009年推出的,差了8年
我又没有说不让支持php5这些旧版,只是说默认安装版本改成PHP7.2+MariaDB5.5这些官方还提供安全支持的版本。

TOP

引用:
原帖由 蛋蛋的蛋 于 2019-1-11 22:32 发表
:) 我就惦记 啥时候也能加上 jdk的 可选安装  以及可选版本
这个没有必要啊,没人用,你要用可以用OneinStack带这个的

TOP

引用:
原帖由 i7097611 于 2019-1-20 11:00 发表
其实还有个问题,比如MySQL5.6版本(当然也比较老了),是需要服务器至少要有1G内存,而1G内存的服务器较贵(Vultr至少5$)所以因为图便宜用MySQL5.5版本的(起码512MB内存能够支持) ...
我的建议是使用MariaDB5.5和php7.2来替换,这两个官方安全更新都支持的2020年,我测试使用256m内存的vps都可以安装远行。

TOP