打印

LNMP问题反馈必读

本主题由 licess 于 2017-6-6 08:31 关闭

LNMP问题反馈必读

提问前现在论坛里搜索相关关键词确认是否已经有相关问题及解决方法!
提问前请先到https://lnmp.org/faq.html 查看LNMP常见问题。

为及时有效的解决LNMP安装及使用过程中的问题,请认真阅读提供一下信息:

如果LNMP安装失败:
1、提供你的VPS/服务器系统信息及版本好信息、32还是64位,最好提供服务商名字
2、需要用winscp登陆到服务器上在/root 目录下找到lnmp-install.log,下载下来压缩为zip、7z或tar.gz格式然后上传改文件到论坛,或提供编译安装的错误信息。 0.9及之前版本的日志在lnmp安装目录下面的lnmp.log。
如果安装出错或安装完成后PHP或MySQL或Nginx无法运行,以上两条必须提供,否则无法提供任何帮助!!!!

如果反馈使用过程中的问题,请提供出错的信息。

如MySQL无法启动或运行不正常的话
如显示ERROR! MySQL server PID file could not be found!
必须提供 /usr/local/mysql/var/主机名.err 的日志(如果修改过数据库目录位置,那就在你修改之后的数据库目录下面)。
MariaDB一般是在/usr/local/mariadb/var/mariadb.err
不提供日志无法进行判断。这是基本规则!!!

如nginx不能正常启动
先执行/usr/local/nginx/sbin/nginx -t 测试配置文件是否有错误,发帖时贴上返回信息,必要时提供配置文件。

PHP不正常
执行/usr/local/php/bin/php -v看一下是否有错误提示。

PHP-FPM挂了
php-fpm挂了肯定会显示“Nginx 502 Bad Gateway”,按https://bbs.vpser.net/thread-1144-1-1.html 这个帖子进行排查。

安装PHP模块是安装失败
安装失败必须要提供安装日志,系统版本信息、php版本信息、已安装哪些模块等。总之越详细越利于解决问题。

如升级出错请提供升级日志一般在/root 下面以upgrade_mysql/php/nginx日期.log

Nginx 502 Bad Gateway错误请先按:https://bbs.vpser.net/thread-1144-1-1.html 这个排查

禁止无意义挖坟和回帖,一个问题一个帖子里进行反馈。

无论出现任何问题,请尽可能的提供详细的介绍信息和错误信息。
请勿在本帖反馈,请新开帖子。

论坛上为不定期回复,一般一天2-3次集中处理回复。
急需解决可以进行付费支持服务。联系QQ 503228080 或旺旺:lzhenbao 进行付费支持服务

TOP

回复 7# 的帖子

已经有其他的mysql在运行,kill之后重新启动试试或重启系统试试。

TOP

回复 10# 的帖子

如果是低于192MB内存肯定安装不上,内存太小。

如果是192MB以上的话按置顶贴要求反馈编译安装错误信息。

TOP

回复 13# 的帖子

日志里没有记录下mysql的编译错误信息

TOP

回复 20# 的帖子

/usr/local/php/etc/php-fpm.conf 里
如果pm = dynamic
增大 pm.max_spare_servers的值
如果不是增大pm.max_children的值

TOP

这个不好说自己可以慢慢的网上加着试试

TOP

回复 27# 的帖子

论坛上都说过了,搜一下就能找到 https://bbs.vpser.net/thread-8393-1-1.html

TOP

安装没有问题,不过建议看看程序的兼容性,有些程序是没法再5.4的版本上运行的

TOP

回复 29# 的帖子

安装没有问题,不过建议看看程序的兼容性,有些程序是没法再5.4的版本上运行的

TOP

回复 32# 的帖子

发该虚拟主机的配置文件看看

TOP

回复 34# 的帖子

看配置没错误

TOP

回复 36# 的帖子

Error: Cannot find a valid baseurl for repo: base
Could not retrieve mirrorlist http://mirrorlist.centos.org/?re ... =x86_64&repo=os error was
14: PYCURL ERROR 6 - "Couldn't resolve host 'mirrorlist.centos.org'"
Error resolving pool.ntp.org: Name or service not known (-2)
源有问题,dns设置也有问题https://bbs.vpser.net/thread-3246-1-1.html

TOP

回复 39# 的帖子

wget: command not found
连最基本的wget命令都没有肯定安装失败

而且你系统的yum有问题,而且有其他程序占用了yum

TOP

回复 46# 的帖子

Error: apr-1.5.1.tar.gz not found!!!download now...
--2015-06-09 23:29:44--  http://soft.vpser.net/web/apache/apr-1.5.1.tar.gz
Resolving soft.vpser.net... 218.85.65.150
Connecting to soft.vpser.net|218.85.65.150|:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: http://127.0.0.1/ [following]
--2015-06-09 23:29:44--  http://127.0.0.1/
Connecting to 127.0.0.1:80... failed: Connection refused.

你网络可能有劫持,造成文件没被下载

TOP

回复 54# 的帖子

建议发日志看一下,目前lnmp安装所需要的依赖包里不需要这个

TOP